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1 INTRODUCTION 

1.1 REFERENCES 

Ref 1 Getting Started, “Bathyswath Getting Started.docx”: introductory manual for Bathyswath 
systems 

Ref 2 Online User Guide: context-sensitive help system supplied with the Swath Processor 
program 

Ref 3 Installation instructions, “Installing Bathyswath.docx”: instructions for installing the 
Bathyswath software. 

Ref 4 ITER Systems website, at http://iter-systems.com/  

 

1.2 GLOSSARY & ACRONYMS 

WORDS & 
ACRONYMS 

DEFINITION 

2D Two dimensional: a display showing the grid in plan view 

3D Three dimensional: a display showing the grid as a 3D surface 

ASCII American Standard Code for Information Interchange; industry 
standard for encoding text in computers 

bin One data element in the grid; contains all information whose position 
falls into a square in the horizontal plane 

Detailed grid Bathyswath grid encoded to give full data details 

DTM Digital Terrain Model 

grid Depth information arranged as a regular grid of points 

Normal grid  Bathyswath grid encoded to minimize size in memory 

patch test A method for calibrating the system by computing corrections to the 
mounting angles and positions of the components of the system, 
using overlapping data sets 

skew Rotation of something (generally a transducer) around its own axis 

XYZ Horizontal and depth 

 

1.3 PREFACE 

The Bathyswath User Documentation covers all models in the series. The documentation is 
divided into these main parts: 

Getting Started - the paper part of the documentation, which introduces Bathyswath and 
covers aspects such as software and hardware installation and deployment. 

Online User Guide - covering all aspects of using Bathyswath as a hydrographic surveying tool. 
The guide is accessed from the Swath Processor Help menu.  

Grid Processor manual – This document: this provides instruction for using the Bathyswath 
Grid Processor program. 

  

http://iter-systems.com/
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Installation instructions – the software and other components are supplied with specific 
installation instructions, which build in the installation guides provided in this manual. 

Auxiliary equipment manuals – Bathyswath is usually supplied with auxiliary equipment, such 
as attitude sensors, positioning systems and compasses. These will have been supplied with 
their own manuals and/or online guides, and the operator should also read these before using 
the system. 

 

This manual is in four main parts: 

• An introduction to Grid Processor (section 2) 

• Instructions for using the program (sections 3 to 14) 

• A summary of the user controls available (section 15) 

• Background technical information about the program (section 16) 
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2 INTRODUCTION 

2.1 WHAT GRID PROCESSOR IS 

Grid Processor is a software tool for use with the Bathyswath swath bathymetry system. It can 
also be used with data from other sonar systems.  

Grid Processor is designed to perform the following tasks: 

◼ Data quality control 

◼ Post-processing calibration, using a "patch test" procedure 

◼ Storing the sonar data in a regular geographic form for output to charting and 
visualisation software packages 

◼ Viewing the bathymetry and sidescan data 

◼ Filtering and manipulating the bathymetry and sidescan data 

◼ Measuring distances and volumes 

◼ Exporting data and printing simple charts 

 

These tasks are carried out by creating numerical models of the survey data collected with 
Bathyswath. Such numerical models are called "Digital Terrain Models" or "DTMs". The DTMs 
are constructed using a regular grid of data points, so that the DTM files are also called "grids". 
The grid files contain not only the depth and amplitude data, but also information about the 
measurements that were used to derive the gridded data. This information is then used to 
compare depth data from different origins in the input data. Such comparison is used to assess 
the quality of the data. It can also be used to derive constant error measurements. These error 
measurements can then be fed back as correction figures into the data set, either within the 
Swath Processor processing software, or within Grid Processor itself. This process is referred 
to as "postprocessing calibration". 
The grid also stores statistical information about the data, which can be used for data quality 
assessment. 

Grid Processor is sometimes called “the gridder”, “Gridproc”, or just “Grid”. 

2.2 MAIN FUNCTIONS 

The main functions of Grid Processor are summarised below. They are also described more 
fully later in this manual. 

2.2.1 Data Import 

The following file formats can be read into the grid: 

◼ Bathyswath processed data files (".sxp"): these files are produced by the Swath 
Processor real-time and post-processing program. 

◼ ASCII xyz text files (".txt" or ".xyz"): these consist of lines of text. Each line gives a 
data point, consisting of Easting, Northing, and Depth fields, separated by spaces. 
This data format is produced by The Swath Processor as well as many other 
programs. 
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◼ Bathyswath grid files (".sxg"). These files are produced by Grid Processor itself.  

The imported data can be filtered before being entered into the grid: see Import Filter (section 
4.3.3). 

2.2.2 Data Export 

The data in the grid can be exported in ASCII xyz format. The details of this format can be 
adjusted to meet the requirements of the program that is to be used to read in the xyz data. 
See Import-Export Format (section 10.1.1). 

2.2.3 New, Open, Close, Save, Save As 

These functions are used with the Bathyswath grid files. 

2.2.4 Print 

The views that Grid Processor creates from the gridded data can be printed to any Windows 
printer (including “Print to PDF” to create PDF files). 

2.2.5 Zoom and Pan 

Zooming is done: 

◼ using the mouse wheel, or by  
◼ clicking on the "zoom drag" button and "lasso-ing" the required area by "click and 

drag" with the left mouse button, 
◼ or using the pg up and pg down keyboard buttons 

 

Panning is done by  

◼ "click and drag" with the left mouse button, or 
◼ The keyboard arrow buttons. 

2.2.6 Defining the Grid Settings 

Once a grid has been created, its parameters must be defined before any data is added.  

The essential parameters are the bin size, the working area of the grid, and whether it is 
“Normal” or “Detailed”: see below. Grid Processor can be configured to grow the grid to accept 
any new data, so it is usually not necessary to know the grid area in advance. 

Each grid bin contains both depth and sidescan information, and the user can display either or 
both types of data. 

2.2.7 Normal and Detailed Grids 

A grid with the full information set included can use up a large amount of memory. In order to 
be able to create a gridded data model of a set of survey data for a large area, or using small 
grid bin sizes, it is often helpful to remove this extra data by using the "Normal" setting. This 
reduces the memory requirement of the grid. However, calibration and quality analysis 
functions cannot be carried out on a Normal (or “summary”) grid.  

A “Detailed Grid” contains information about all the data points that have been loaded into it. 
This mode is required for: 

◼ Calibration, 
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◼ Statistical Analysis, 

◼ 3D “point cloud” views, and any view that needs to display more than one height for 
each X-Y position on the Earth’s surface. 

2.2.8 Calibration 

“Patch test” calibration is carried out on recorded data to obtain precise values for the physical 
and time offsets in the auxiliary data sets. 

Grid Processor is used to obtain the following post-processing calibration measurements: 
depth, roll, heading, pitch, position offset east and north, position offset along and across 
track, and position-time delay. Roll offset has a very strong influence on the depth 
measurements made by Bathyswath; so roll offset is calculated automatically from 
overlapping data lines. Along-track time offsets, pitch and heading are partially automated, 
enabling the user to calibrate along user-selected profile lines. The other calibration 
parameters require more operator judgement, so calibration is carried out by comparing 
overlapping data areas with Grid Processor views, or by using the measure tool in the profile 
line window.  

Once a calibration-offset figure has been determined, it is confirmed using the Shift Data 
function. The calibration offsets can be further refined by iterating the processes of measuring 
offsets and applying them with Shift Data. 

See section 9. 

2.2.9 Shift Data 

The data in the grid can be shifted in the following dimensions: roll, pitch, heading, depth, 
position vs. track, position vs. grid, and position vs. time. 

This shift is very useful for post-processing calibration, but it can also be used to manipulate 
the data before passing it on to other processing systems. 

See section 5. 

2.2.10 Filters 

The data in the grid can be filtered to remove spikes or gaps in the data. The functions provided 
are: de-spike, smooth, remove data, and interpolate. Areas of the grid can be selected to be 
specifically included in or excluded from the filtering process. 

See section 6. 

2.2.11 Information 

The program supplies the following information about the grid and the functions that have 
been applied to it: 

◼ Debug: allows the details of the grid to be analysed at a deep technical level. 

◼ Process log: keeps an audit trail of all the processes that have been applied to the 
grid. This audit trail is stored with the grid file itself, and may also be stored as a 
separate text file. 

◼ Imported files: gives a list of the names of the files that have been imported into the 
grid. 
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◼ Process summary: summarises the results of the calibration processes, etc. 

These items are available under Info in the menu bar. 

2.2.12 Views 

The grid data may be viewed in several ways: 

◼ As a coloured depth map; this shows each bin as a coloured pixel. The colour is 
determined by the data type selected for viewing (e.g. average depth, standard 
deviation, etc.), and the colour scale chosen, as well as sun illumination if this option 
is selected. 

◼ As a depth profile across a line drawn across the grid area. 

◼ As a 3D coloured depth map with various options to alter the visual quality and 
viewing angle, etc 

In addition, the survey line tracks and other information may be superimposed on the grid 
data, and background maps from other sources may included as background images.  

See section 4.4. 

2.2.13 Measurements 

It is possible to extract several kinds of measurement from the grid: 

◼ Profile: the line which is used to show a profile of depths is selected by clicking on 
the Select Profile button, and then using "click and drag" to select the endpoints of 
the profile. 

◼ Measure: the length and bearing of a line across the grid can be displayed. Also, the 
extra grid information is accessed to show measurements such as the nearest survey 
lines and ping numbers, and the speed over the ground between those pings. This 
measurement is made by clicking on the Measure button, and using "click and drag" 
to select a line across the grid. 

◼ Status: this is accessed by clicking on the Status button, and then on a point of 
interest in the grid. A dialog appears showing all the information associated with that 
grid point. 

◼ Status bar: the status bar at the bottom of the screen constantly displays the 
position, value, and value count of the grid bin that lies under the position of the 
mouse pointer (provided that there is data at this position). 

◼ Volume: compute the volume of the whole grid, or in a selected area of the grid. This 
is typically used to compute the volume of change between one grid and another, by 
first computing a difference grid and then computing its volume. Use the Tools > 
Calculate Volume. 

2.2.14 3D Viewing 

The grid data may be viewed in 3D using OpenGL accelerated graphics. There are various 
options open to the user, briefly summarised below: 

◼ View a coloured heightmap (filled or wireframe), or point cloud, or a combination of 
the two. 
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◼ Rotate, zoom, fly through using the mouse and keyboard in full 3D. 

◼ Select a navigation path and let the computer fly through it in 3D. 

◼ Access a variety of options including lighting properties, optimisation options, and a 
representation of the sea surface. 

◼ Change the angle of the lighting to bring to light interesting features on the seabed. 

◼ Select interesting or outlying points in the point cloud to highlight or delete. 

◼ Select in 2D and reset to default the 3D view, should you get lost… 

 

See section 14 
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2.3 GETTING HELP FROM THE PROGRAM 

When Grid Processor is running, you can get help on running it using the Help item in the Menu 
bar. 

Key & Mouse Commands opens a window with a summary of the commands available; the F1 
key also opens this window 

Show manual opens this document.  

 

2.4 OTHER INFORMATION 

For more information on the Bathyswath series of swath bathymetry systems, please refer to: 

"Bathyswath: Getting Started"; [Ref 1] this is the paper manual that introduces the Bathyswath 
systems. It introduces the systems, and then describes how to install and deploy the hardware 
and software of the systems. 

"Bathyswath Online User Guide"; [Ref 2] this is an active help system that resides on the 
Windows computer. It describes the functions and use of the Bathyswath systems in detail, 
and then goes on to describe the use of the Swath Processor real-time and post-processing 
program. 

The ITER Systems website, [Ref 4] 

 

  

http://iter-systems.com/
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3 USING THE GRID PROCESSOR 

3.1 REQUIREMENTS 

Grid Processor is tested with Windows 10. However, it has run satisfactorily under other 
versions of Windows.   

When gridded data models are created for calibration or quality control, the grid retains a large 
amount of the detail of the original data set. The memory and disk requirements of the 
program can therefore become very large, especially if large areas or small grid bin sizes are 
selected. Therefore, a large memory and disk are recommended for use with the Grid 
Processor.  

The program will also run faster with a powerful processor. The limiting factor in grid 
processing tends to be memory capacity. This is restricted on 32-bit processors. Grid Processor 
works on 32-bit computers, but use of 64-bit processors is strongly recommended. 

For the 3D view, it is recommended that a fast processor and/or good 3D graphics accelerator 
(128 MB at least) is used for good performance at the highest detail and for large grids.  

Large grids, or those with small bin sizes, or using the “Detailed” option, will slow down 
processing and visualisation. Some experimentation may be needed by the user to find the 
best balance between the use of these options and the processing power that is available. 

3.2 INSTALLATION 

Grid Processor is installed from the Bathyswath software installation application, 
“bathyswath_x64.msi” (for 64-bit processors) or “bathyswath_x86.msi” (32-bit). 

3.3 STARTING THE SOFTWARE 

The installation software places shortcuts to Grid Processor in the Windows Start menu and 
on the Desktop. 

It also creates a link to “*.sxg” files, so when you double-click on a Bathyswath grid file, it will 
open in Grid Processor. 

3.4 APPEARANCE 

A typical Grid Processor screen appears as follows.  
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3.5 CONTROLS 

There are four main ways that you can control Grid Processor:  

• The Menu Bar: menu topics at the top of the main window 

• The Toolbar: a row of buttons giving access to the main functions  

• Key shortcuts: sequences of keyboard presses for fast access to functions 

• Context menus: right-click on the grid view windows to get a menu of functions 

 

Also see section 15 for a summary of available controls. 

 

3.5.1 Menu Bar 

 

• File 
o Creating, opening and closing grid files 
o Importing and exporting data 
o Printing 

• Edit 
o Copy, cut and paste 
o Only works in a few special functions 

• View 
o Enable and disable menu bar and toolbar, etc. 
o Zoom in and out 
o Toggle 2D and 3D views 

• Window 

Title bar 

Name of 
selected grid 

Menu bar 

Tool bar 

Grid 
views 

Status 

Grid data at 
cursor 

location 
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o Create windows 
o Arrange windows 
o Select windows 

• Settings 
o View and set parameters of grids 
o Add title and subtitle 
o Etc. 

• Tools 
o Calibration functions 
o Filters 
o Select and export profiles 
o Measure 
o Calculate volumes 
o Mark and delete data (in 3D view) 

• Info 
o Show details of the selected grid 
o Show a log of processes done to the current grid 
o List the files imported into the current grid 
o Show a summary of processes on the grid (e.g. calibration results) 

• Help 
o Version number of Grid Processor 
o Summary of key and mouse controls 
o Show this manual 

3.5.2 Toolbar 

The toolbar buttons are: 
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3.5.3 Key Shortcuts 

Most control functions of Grid Processor can be done using the computer keyboard; this can 
make operation faster when you have learned a few of them. 
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See section 15 for a list of commands and key codes, or use the Keyboard Commands key  

( ) or Help > Key & Mouse Commands in the menu bar to get a dialog showing a summary 
of key codes. 

3.5.4 Context Menu 

Right-click on the grid view windows to get a context menu. 
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4 CREATING AND VIEWING A GRID 

4.1 INTRODUCTION 

This section, and the ones that follow, are written in the form of a “tutorial”, a step-by-step 
run through a typical Grid Processor session. 

4.2 REQUIREMENTS 

To run this tutorial, you will need at least one Bathyswath Processed Data file. These are 
created by the Swath Processor program. They may be recognised by the file extension ".sxp". 
Contact the Bathyswath support team at support@iter-systems.com for example data files. 

4.3 CREATING AND STORING 

4.3.1 Creating a Depth Grid 

Start Grid Processor as described above.  

Select File from the toolbar at the top of the Grid Processor window, and select New (or use 
the New button). 

A Grid Settings dialog opens that allows you to set the grid parameters. Change from Normal 
Grid to Detailed Grid, and otherwise use the default settings for now; click OK. 

 

You can change some of the grid settings later by clicking on Settings in the toolbar, and 
selecting Grid. Note that the Grid… entry in the Settings menu includes the text “… Ctrl+G”. 
This means that the same function can be achieved using the shortcut key sequence of holding 
down the Control key, and pressing the G key. Many of the other Grid Processor functions have 
similar shortcut key sequences. These sequences are similarly shown in the toolbar menus, 
and listed in Shortcut Keys in this manual. 

Note that you cannot change the bin size once it has been set, and nor can you change from 
Normal mode to Detailed mode (but you can change in the other direction) If you make a 
mistake, close the grid and start a new one. 

 

4.3.2 Importing Data into the Grid 

Open the import file selection dialog by selecting File in the toolbar, then Import…. 
Alternatively, click on the Import button. You can also drag-and-drop files from Windows 
Explorer into the grid window. 

Use the file selection dialog to locate the processed data file ".sxp" that you wish to import. If 
you wish, you can select more than one file for importing. Hold down the "select" key when 
clicking on the last file in the list to select all the files between first and last, or hold down 
"control" whilst selecting to select individual files from the directory. Click on Open, or if 
selecting just one file, double-click on the file.  

The depth data will be read into the grid: a progress bar dialog will open to show how the 
import is progressing. When the import is complete, the depths will be displayed as a colour 
map in the view section of the Grid Processor window. 

 

mailto:support@iter-systems.com
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You can import data in text format, or import other grids, by using the drop-down list at the 
bottom-right of the Open dialog box, changing from “Processed Data Files (*.sxp)” to the 
format that you want to import. 

4.3.3 Import Filter 

You can filter or change data before it is imported. Use the Tools > Import Filters dialog. 

The default is to merge new data into existing data in the grid. Alternative available include: 

◼ Subtract import data from existing 
This can be used to compute the difference between two datasets 

◼ Don’t overwrite existing data 
Data is only written into grid bins that are currently empty. This can be useful if you 
want to use a secondary set of data to fill in gaps in the main dataset. 

◼ Invert Z on import 
This changes the sign of depth values from positive to negative. Grid Processor uses a 
positive-down convention (so heights above water are negative). If you are using land 
survey data, then the opposite convention is usually used. 

◼ Import rejected data 
Bathyswath processed data (.sxp) includes a flag for indicating rejected data points. 
Grid Processor does not import rejected points unless you use this option. 

◼ Import interpolated data 
Similarly, Swath Processor can interpolate between measured data points if required, 
but Grid Processor does not import such data points unless you use this option. 

 

Data can be filtered by position; use Filter Position on Import and enter minimum and 
maximum easting and northing values.  

Grid processor normally expands the grid area as new data points are imported. But if a false 
data point is imported, then the grid can grow enormously and so exceed memory limits. To 
prevent that, use the Max distance to expand grid setting. 

 

You can limit the range (distance from the transducers) of data that is imported. This can be 
useful to filter out poor-quality far-range data. Use Filter range on import and set minimum 
and maximum ranges for each transducer. 

You can also select a minimum and maximum depth for imported data, using Filter depth on 
import. 

 

4.3.4 Saving the Grid 

Once depth data has been imported, it is a good idea to save the grid. Simply select Save or 
Save As... from File, or click on the Save button, or use Ctrl & S keys. Use the file chooser dialog 
that appears to select a name and location for the grid. 

If the file hasn’t been saved yet, a dialog box appears, asking you to provide a name and 
location for the file.  
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Get in the habit of saving the file to a new name each time you do something irreversible to 
the grid (which includes most import and filter functions). You can then go back to a previous 
version if you make a mistake. Use file names that are meaningful for the data content and the 
processes that have been performed. 

4.3.5 Checking What You Have Done to the Grid 

Don't worry if you forget what files have been imported, or what processes you have 
performed. You can use the Info toolbar options to find out. These include: 

◼ Grid Details: this gives a "drill-down" interface to the grid data. It probably contains a 
lot more detail that you will ever need. 

◼ Process Log: every time anything is done to the grid, a text entry is made to the Process 
Log. It therefore forms an audit trail for the grid processing. 

◼ Imported Files: this lists the name of the data files that have been imported to the 
grid. It also gives the line number that each file has been given in the grid. This is useful 
for cross-referencing .sxp file names with line numbers in Grid Processor. 

◼ Process Summary: this is used when calibrating and shifting data in the grid. It gives a 
running total of the shifts made and an average of the calibration values measured. 

4.4 VIEWING 

4.4.1 Examining the Depth Data in the Grid 

There are many ways to examine the data that you have just imported. Here are a few of the 
commonly used ones: 

Locate the mouse pointer over the view area in a location where depths are displayed (the 
coloured region). Look at the status bar at the bottom of the Grid Processor window. It will 
show the position as Easting and Northing, the depth as Value, and the count of data points 
entered into the grid as Count. Move the mouse pointer and watch these values change 
accordingly. 

The easting and northing position extents of the area displayed are shown in the position grid 
at the edge of the view area.  
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From Tools in the toolbar, select Show Status. You can do the same with the Status button 
(this has a “?” symbol on it). Then, click the mouse pointer over an area of the view with data 
in it. A dialog will appear, showing the number of points, minimum, maximum, average and 
standard deviation of the depth values at the selected location. This is the summary data for 
that data point. If the grid is created in Detailed mode, you can now "drill down" through the 
data stored at this location to investigate its details. At the bottom of the display there are one 
or more "Lines" listed: "Line 1", "Line 2", etc. When the data is imported, a new survey line 
number is created, and the data imported from that file is tagged with the survey line number. 
In this case, you have imported only one line, so the dialog will only list "Line 1". Double-click 
on "Line 1". The dialog text now expands to show the summary data for Line 1. As there is only 
one line at this stage, the summary data for the whole bin and the selected line should be the 
same. Now, one or more pings will be listed at the bottom of the text in the dialog. A "ping" is 
a single sonar transmit-receive cycle. Each ping is given a unique "ping number" by the real-
time software (Swath Processor). Double-click on one of these pings, and the text expands 
again to show the data within that ping. Double-click on the other pings, to expand them, too. 
You can now see how the summary data is built up from its line and ping constituents. Click on 
OK to close the dialog. 

From Tools, select Measure, (or click on the Measure button). Place the mouse pointer over 
the view area, and push down the left mouse button. Keep this button held down, and pull the 
pointer to another location in the view area. Notice that the pointer changes to a box, with 
one corner at the original location of the pointer and the opposite corner at the current 
location of the pointer. When the box covers an area of interest, release the left mouse button. 
(This process is called "click and drag"). A dialog appears, showing all the available information 
for the line between the two selected points in the grid. This information includes the distance 
and bearing of the line, as well as the nearest ping to the first point selected, and the survey 
line that this ping came from. It also shows the nearest ping in the same survey line to the 
second selected point, and the distance, time and ground speed between these two pings. Of 
course, this speed information is only relevant to the selected line if the line was selected to 
run approximately parallel to the direction of the survey line. Click on OK to close the dialog. 

4.4.2 3D and 2D Views 

The grid can be viewed in plan view (2D), or as a three-dimensional (3D) view. The 3D views 
are explained in a separate section; the rest of this section describes the 2D views.  

Change between 2D and 3D views using the 2D/3D button in the toolbar, or pressing the F3 
key. 

4.4.3 Modifying the Area Viewed 

There are several ways to zoom in and out (i.e. to change the viewing scale). These are: 

◼ From View in the toolbar, select Zoom In or Zoom Out. There are also buttons 
provided for this in the toolbar, and you can use the PGUP key to zoom in and the 
PGDOWN key to zoom out, or you can use the mouse wheel. Roll the mouse wheel 
forwards: the display zooms in. Roll it back, and the display zooms out. 

◼ From View, select Zoom Drag. Then use "click and drag" to define the new display 
area. Again, there is a Zoom Drag button. This only works in 2D: click and drag in 3D 
rotates the view around a central point.  
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◼ From View, select Zoom Extents. The view area enlarges to show the whole area of 
the grid. There is a button, of course. 

◼ From View, select Zoom Choice. A dialog appears, prompting you to enter a specific 
set of extents as north, south, east and west. This function is useful if you wish to 
compare a specific area from two or more grids. As this is not used that often, no 
button is provided. 

◼ Use the arrow keys on the keyboard to pan left, right, up and down.  
◼ To pan the display with the mouse, (move the location viewed north, south, east or 

west), click and hold the left mouse button over the view. Then, holding the button 
down, drag the pointer the to a new location. The data viewed moves in the direction 
of the drag. (In fact, the view area moves in the opposite direction to the drag). 

4.4.4 Changing the Data Viewed 

By default, the display shows the average depth of all the data within the grid bins. However, 
you can change this using the view context menu. To access this context menu, click the right 
mouse button over the view area. Select View Type, and then move the pointer to the right at 
this location and select the view type required, for example Standard Deviation. The display 
is now coloured according to the new data type. Now, you will probably find that the colouring 
mechanism is no longer appropriate for the new data type. For example, a new colour for each 
1.0 metre is fine for depths, but we would hope that the range of standard deviation is not as 
great as that of the depths itself. To modify the colour range, see "Colours" below.  

4.4.5 Selecting Survey Line to View 

Normally, the data shown comes from an average of all the survey lines. Instead of this, you 
can elect to show the survey lines in order, one on top of the other, or just show one line at a 
time. The view context menu Line Data setting allows you to select Average, where the 
average depth is shown, First, where the lowest-numbered line is shown on top, Last, where 
the highest-numbered line is shown on top, or Selected, where just one line is shown. The 
selected line is changed using the control and up arrow or down arrow keys on the keyboard. 

4.4.6 Colours 

To change the colouring mechanism used to colour the grid bin colours, select Colours from 
the context menu.  

Colours are shown using one of three methods: Bands, Range and Fixed. These methods are 
selected using the Colour Type combo box at the top of the Depth Colours dialog box. 

  



 

 

The information contained on this sheet is subject to restrictions listed on the cover page of the document 

Version 5.13 – 19/10/21 Page 18 ETD-2003 

Unclassified 

www.iter-systems.com  

support@iter-systems.com 

◼ Colour Bands: this method assigns separate colours for bands of depth values. The 
width of the colour bands is defined by the "Colour Band Range" setting. For example, 
as value of 1 in this box means that all depths from 0 to 1.0 are assigned to the first 
colour, values from 1.0 to 2.0 are assigned to the second colour, and so on. The colours 
used are defined by the "Number of Colours" setting. For example, if a value of 10 is 
used in this box, then the colour range available to the system, (starting at red and 
ending at violet) is divided into ten colour blocks. Once the colour bands have been 
used up, then the colour cycle is re-started. So, in the example of Colour Band Range 
set to 1.0 and the Number of Colours set to 10, then the cycle of colours re-starts after 
10 metres. In other words, in this example depths of 0.0 to 1.0 are assigned the same 
colour as 10.0 to 11.0, 1.0 to 2.0 has the same colour as 11.0 to 12.0, and so on. The 
colours may be further sub-divided using the "Number of Shades" setting. This breaks 
down each colour band into more bands, differentiated by the lightness or darkness 
of the colour. So, for example, if "Number of Shades" is set to 5 in the above example, 
then depth values from 0.0 to 1.0 are assigned to the same colour as before, but depths 
from 0.0 to 0.2 are given one shade of that colour 0.2 to 0.4 another shade, and so on. 

◼ Colour Range: this method assigns all the colours available to the system to depths, 
starting at red for depth values less than or equal to the Minimum setting, and violet 
to colours greater than or equal to the Maximum setting. This colouring method only 
works effectively if the correct depth range is entered. You can see the depth ranges 
within the area of interest by looking at the colour scale at the right of the view 
window. This automatically adjusts itself to the range of depths within the current view 
window. 

◼ Fixed: this method allows you to define a fixed colour for each step in depth, starting 
at a minimum depth. This takes longer to set up than the other methods, but is useful 
if you have a pre-defined colour regime that you wish to use in Grid Processor. 

Sidescan grids create a greyscale image using the Colour Range algorithm, but using an 
intensity scale from black to white, rather than a colour scale from red to violet. 

In general, Colour Range produces an image that is more pleasing to the eye, but Colour Bands 
allows finer control over the depth resolution that can be seen. In either case, the colour scale 
at the right of the screen shows the colour given to a range of depth values. 

4.4.7 Sun Illumination 

Sun Illumination is another colour option available in the Colours dialog in the view context 
menu. It shades the view based on a light source that is set to a direction according to the 
slider controls for horizontal and vertical angles. The vertical angle (elevation) goes from 
horizontal (left) to directly above (right). The horizontal angle (azimuth) moves in a full circle 
when the slider is moved. The choice of greyscale illumination or illumination overlaid onto 
the colour map may be switched using the Colour Illumination option. 

This option is useful for showing fine detail and texture. 

4.4.8 Grid Overlay 

The program shows an overlaid grid of position lines. The spacing between these is chosen 
automatically to give a reasonable number of lines, at regular intervals. If the gridlines are 
obscuring details in the display area, select Short Gridlines from the view context menu. This 
reduces the grid lines to short "ticks" at the edge of the display.  
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4.4.9 Survey Lines 

The location, direction, and number of the location of the ship as it ran the survey lines can be 
shown on the display, by selecting Show Survey Lines from the context menu. The number of 
each line is shown in a circle at the start of each line, and an arrowhead is placed at the end of 
each line. 

4.4.10 Creating More Grids and Views 

Within the same program you can have as many grids open as you like, and have several 
different views of each. 

To create a new grid, select New from the File toolbar option, or click on the New button. 
Before you can import data into this grid, you must define its grid parameters in the Grid 
Settings dialog box that opens. You can enter the bin size, grid limits, and so on as before. 
However, you now have the option to use the same settings that you used before. There are 
two ways to do this: 

◼ Use Previous: this button sets the grid settings to the same as they were last time the 
OK button in the Grid Settings box was clicked, within the same Grid Processor session.  

◼ From File…: this button opens a file chooser dialog. The grid settings are set to those 
of the file that you select. 

When you have more than one grid open, you can switch between their views by selecting the 
grid file name from the bottom part of the Window menu in the toolbar. Alternatively, you 
can show all the grids at once using the Tile or Cascade options from the Window menu. The 
grid that is currently active is highlighted in the bar at the top of the view. Commands such as 
import, filter, and so on will act on the active grid. 

You can have two or more views of the same grid. Select New Window from the Window 
menu. This will open a new window showing the data in the active grid. You may need to use 
the Zoom Extents button after opening the new window. The new view can be zoomed, 
panned, coloured, etc. completely independently of the original view. 
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5 MODIFYING THE GRID DATA 

You can change the data in the grid using Tools > Shift Data. 

Options for shifting are selected under Shift By. In Normal mode grids, only the first two can 
be used. 

◼ Depth: increase or reduce depth values 
◼ Position vs Grid: move the data in easting and northing 
◼ Roll: rotate data points around the transducer position in roll. Can be used after roll 

calibration. 
◼ Pitch: rotate data points around the transducer position in pitch 
◼ Heading: rotate data points around the transducer position in heading 
◼ Position vs Track: move data points in the direction of the ship’s track 
◼ Position vs Time: move data points in the direction of the ship’s track to account for 

time offsets between position data and sonar data 
◼ Elevation and skew: used with a forward-look transducer for gap-filling. Select the 

number of the transducer that this applies to (usually transducer 3). 

 

If Shift All Lines is selected, then the data from all survey lines in the grid is changed. If not, 
you can specify a line number to be changed. 

 

Click Start Shift to modify the data in the grid. 
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6 FILTERING THE GRID DATA 

Start with a grid with imported data, such as one created in section 2.2.1. 

6.1.1 Undoing Filters 

Grid Processor does not provide “undo” functionality. So before starting each filter, you may 
wish to save the grid to a new name. For example, if your grid was called "grid1.sxg", use Save 
As to save it as "grid1 unfiltered.sxg". 

6.1.2 Selecting and Starting Filters 

From Tools in the toolbar, select Filters. A tabbed dialog bar appears. 

6.1.3 Filter Area 

In the Filter Area tab, select the area to be filtered. Your options are: 

◼ In Whole Grid: this filters the whole grid, and so ignores any area that you may select, 
◼ In Selected Area: this filters inside the selected area, and ignores the area outside, 
◼ Outside the Selected Area: this filters the whole grid except for the selected area. 

To select an area, choose one of the latter two options above. Then, either: 

◼ Enter the area bottom-left and top-right corners into the edit boxes in the dialog, or, 
◼ Click on the Set button, and use click-and-drag to select the required area in the grid 

view window. 
◼ Click on the Set Complex button, and click once on the 2D grid view to select the first 

node of the grid area. Click again for the next node: the area selected will start to 
appear as polygon in the view. Double-click to end the polygon. If you made a mistake, 
press the esc button on the keyboard to remove the last-entered point. 

◼ Click Read from File to read the filter area from a text file (see below) 

6.1.4 Filter Area Files 

You can save the filter area polygon to a file for use in other grids or as a reference with Write 
to File, or you can read one in to use with Read from File. 
The file is an ASCII text file, with a .txt filename extension. 

Each node of the polygon is on a separate line, as (easting northing). For example: 
369256.640 3020494.210 

369216.110 3020349.790 

369175.570 3020205.370 

6.1.5 Running Filters 

The other filters each have their own tabs. To use the filters, click on the appropriate tab to 
bring the filter dialog to the front of the dialog window. Then, enter the required settings, and 
click on Start Filter to start the filter running. If you wish to enter settings, but not run the filter 
process immediately, click on Apply but not on Start Filter. 

Before you start a filter, it is often a good idea to save the grid to a new name first. The filter 
processes are not reversible; they cannot be undone once you have clicked on Start Filter. In 
practice, you will come to your own balance between saving the grid frequently and losing 
work to mis-applied filters. 
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Also, note that some of the filters delete some or all of the statistical and auxiliary survey data 
in the grid. You therefore need to exercise caution when filtering before calibration or quality 
control sequences. 

While the filter process is running, a progress box appears, showing how much of the grid has 
been filtered so far. Most of the filters place the filtered data into temporary storage during 
the first filter stage. Once the whole grid has been filtered this way, the filtered data is entered 
back into the grid in the "Refreshing Grid" stage. 

The progress dialog box includes a Cancel button. This halts filtering partway through the grid. 
Use this button with caution, as the results can be unpredictable, particularly if the Refresh 
stage is cancelled. It is recommended that you return to a saved version of the file if you need 
to cancel a filter process. 

6.2 REMOVING DEPTH SPIKES 

Depth spikes are depth values that differ strongly from the surrounding area. You can identify 
these by setting the colour band setting to a higher value than normal; say 2 metres. Any depth 
values that differ markedly from their surroundings will then show up as specks of different 
colour. You can confirm this by placing the cursor over the points and reading off the depths 
in the status bar at the bottom of the screen. 

To remove these spikes, select Tools from the toolbar, then Filters. When the filters dialog 
appears, select the De-Spike tab. Select a sliding window of 3 units for now (this is the 
minimum setting), and use a …deviating by setting of 1.0 metres. Keep the … is less than … 
% full setting at the default of 20% for now. Click on Start Filter, and wait for the progress 
dialog to complete both the filter and refresh stages. 

Use the viewer to check that the spikes have gone. If you find that, in areas where the data is 
sparse, there is not enough surrounding data to be sure that the depth values are unreliable, 
you can repeat the de-spike filter with a % full setting of, say, 50%. This has the effect of 
removing all bins that are not supported by surrounding bin counts of 50% or more. 

If, on the other hand, you feel that the filter has been too harsh, go back to the unfiltered grid 
that you saved before filtering, and run the filter again with a larger depth difference or a 
smaller % full setting. 

You can increase the reliability of the filter by including more data in each comparison, using 
a larger window size. However, be careful that you do not remove data due to real seabed 
shapes: the larger the window, the more chance there is that depth differences are due to 
seabed slopes, not errors in depth measurement. 

Suppose there is an area inside the grid that you have reason to believe to genuinely have high 
differences in depth: a wreck for example. You can exclude this using the Filter Area tab. Select 
Outside Selected Area, and click on the Set button. Then, move the mouse pointer to the grid 
view area. Hold down the left mouse button with the pointer to one side of the area to be 
excluded from the filter. Then, move the mouse with the left button held down, and "lasso" 
the area of interest. Release the mouse button, and confirm that the correct area co-ordinates 
appear in the Filter Area window. Then, go back to the De-Spike tab and run the filter. 
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You can select complex areas (i.e. areas not defined within a rectangle) for filtering using the 
Set Complex Area tool. Using the Filter Area tab, select Outside Selected Area, and click on 
the Set Complex Area button, and then click on the grid. A point will appear showing your 
chosen position. Click multiple times at the points you wish to exclude, or click and drag over 
a line to draw a curved line over the grid, and let go when you want to end the curve. Double 
click at the last point you wish to make. This will filter everywhere except inside the complex 
area you selected. 

6.3 SMOOTHING THE GRID 

Run this filter if you have removed all the spikes, but the contours still appear very "bitty". It 
also helps to fill in small gaps in the grid, for example where the vessel's forward speed has 
not covered one bin for each ping.  

Don't forget to save the grid before running the filter, as its results cannot be undone. 

Click on the Smooth tab in the Filters dialog.  Select a sliding window of 3 bins to start with 
(this gives the minimum smoothing effect). Use using values from … only the same line. 
Otherwise, values from different survey lines will be run together, and any subsequent 
calibration processes will be invalid. 

Use change … all values to smooth the grid. If you want to fill gaps without smoothing existing 
data, you can use only empty grid bins. 

Click on Start Filter, and wait for the process dialog box to complete filtering and refreshing 
the grid. 

6.4 REMOVING DATA FROM THE GRID 

To remove all the data from inside a defined area, use the Filter Area tab to select the area 
(see Removing Depth Spikes for step-by-step instructions. Then go back to the Remove Data 
tab, and select All Data. Click on Start Filter. When the process completes, use the view to 
check that the data has gone. 

If you want to select specific data from the grid, clear the Any Value setting to enable the 
others. You can select any combination of these. For example, to remove noisy data from the 
grid, you could select  

◼ Value Less Than to a minimum expected depth for the area, 
◼ Value More Than to a maximum expected depth for the area, 
◼ Standard Deviation to, say 0.5, 
◼ Range More Than to, say 2 metres, 
◼ Count Less Than to, say 2, 
◼ Max. Horiz. Range to a range that you can accept and maintain overlap in your grid 

(far-range data is more likely to be noisy). 

Click on Start Filter as usual. 

If you import a data file into your grid, and subsequently decide that you do not want it 
included, you can delete all the data in a given line with the Line Number of selection. 
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6.5 FILLING GAPS 

You have seen how to remove gaps using the Smoothing Filter. You can do the same thing in 
a slightly different way using the Interpolate Filter. Select the Interpolate tab in the Filters 
dialog, and set the maximum range tab to the maximum number of grid bins that you wish to 
interpolate over. 

 

When complete, save your grid to a new name. 

6.6 PROCESS LOG 

You can check what you have done to a grid using Info, Process Log. This lists all the filters that 
have been applied. If you need to make a processing report as part of your processing exercise, 
open the Process Log dialog, and click the Save to File button. Then, use the file chooser to 
select a name and location for you report file. 

6.7 FILTERING IN 3D 

In 3D view mode, spurious depth points can be easily and quickly marked and deleted. See 
section 14.4. 

This mode is particularly useful when the surface to be filtered is complex, with targets at 
several different depth levels at the same positions. 
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7 MEASUREMENTS 

You can make measurements on the grid data. 

7.1 MEASURING BETWEEN TWO POINTS 

With a grid shown in 2D, use the mouse to click-and-drag between two points on the grid. 
When you release the mouse button, a dialog appears showing: 

◼ The distance between the two points selected, 
◼ The bearing (heading) from the first point to the second, 
◼ The nearest pings to the two points, and the SXP data files that they came from, 
◼ The distance and time between the two pings, and the speed of the vessel between 

those points. 

7.2 EXAMINING A DEPTH PROFILE 

You can see a profile of depths along a line in the grid. See section 8.4. 

7.3 CALCULATING VOLUMES 

You can calculate the volume across the whole grid, or in a defined area. This is typically used 
to calculate the volume of change between two surveys taken at different times, for example, 
before and after dredging. 

 

IMPORTANT NOTE: ITER Systems can take no responsibility for the accuracy of these 
computations: it is the responsibility of the surveyor to make the necessary quality checks 
to verify the results shown in Grid Processor. 

 

The volume calculation function is accessed using Tools > Calculate Volume. 

The area that is used for this calculation is set using Tools > Filters > Filter Area. See section 
6.1.3. 

 

7.4 COMPUTING THE VOLUME BETWEEN TWO SURVEYS 

To compute the volume between two surveys: 

◼ Process the two surveys in Swath Processor and Grid Processor in the usual way, 
creating a grid file for each, e.g. “grid1.sxg” and “grid2.sxg”. 

◼ Save a copy of the first grid, calling it, for example, “difference.sxg” 
◼ In “difference.sxg”, Set Tools > Import Filter > Subtract import grid from existing 
◼ Import the second grid into the difference grid: use the Import function, and change 

“Processed Data Files (*.sxp)” to “Grid Files (*.sxg)” in the selection box at the 
bottom-right of the Open dialog.  

◼ Accept the warning about data in the grid being destroyed 
◼ If you only want to see the volume change in part of the grid, use Tools > Filters > Filter 

Area. 
◼ Select In Selected Area 
◼ Either: 
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▪ Click Set, and click-and-drag with the mouse to select a rectangular area, 
or 

▪ Click Set Complex, and click on a set of points on the grid to define an area 
of interest. Double-click to finish the area, or 

▪ Use Read from File to read in a set of easting-northing points defining the 
area of interest. 

◼ If you don’t choose an area, the whole grid is used for the volume calculation 
◼ Select Tools > Calculate Volume 
◼ A dialog box appears, showing: 

◼ The area used 
◼ The number of bins with data in them inside the area used 
◼ The signed volume: in this calculation, positive differences cancel out with 

negative differences 
◼ The unsigned volume: in this calculation, positive and negative differences add 

together as all positive numbers 
◼ The signed mean depth (positive and negative cancel out) 
◼ The unsigned mean depth (all differences treated as positive) 

◼ You can see this information after the dialog is closed, using Info > Process Log 
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8 QUALITY CONTROL 

8.1 EXAMINE A SINGLE GRID BIN 

Using the ‘?’ button in the Toolbar (query grid bin), you can get information on the data in one 
bin of the grid. Click on the ‘?’ button, and then click on a bin on the grid that has data in it. A 
dialog box with open: 

 
 

This information is most useful in “Detailed” mode, where information about separate depths 
in each bin is retained. 

 

8.2 EXAMINING A SINGLE LINE 

Start with a new file with one survey line imported into it. To evaluate the quality of the single 
line, try the following steps: 

1. Use the grid view to look at the depths. Look for the following: 

◼ Grid spikes: are there any bin values that stand out strongly from the rest? These 
show up more clearly if you set the colour band higher than usual, say 2 metres. 

◼ Are there any features that run in the direction of the survey? These can be caused 
by incorrect roll angles, heading offsets, and so on. See the Calibration section for 
information on how to remove roll angle errors. 

◼ Are there any depth "waves" that run parallel to the direction of the track? These can 
be caused by bad motion sensor corrections. 

2. Use the View Type > Standard Deviation setting to look for patches of noisy data. You 
will need to reduce the colour banding setting to bring out standard deviation trends 
effectively: try 0.1. You should see that the standard deviation increases from the centre 
of the track outwards. The colour scale on the right-hand-side of the display will show 

2D 
Distribution 

of depth 
points in the 

bin 

Frequency 
histogram of 

depths in 
the bin 

Statistics of depths in the bin 

Data in lines and pings; click on lines and pings 
to expand 
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the range of standard deviations in the current view area. Look for any bad patches. You 
can filter out areas of bad standard deviation directly: see "Removing Data from the 
Grid", above. 

3. Another approach with standard deviation is to use the Standard Deviation display 
setting, and gradually decrease the colour banding until the seabed features just start to 
appear in the view. (You can switch back to the Average view setting, or use a separate 
window in the same grid to confirm which features are due to seabed topography). This 
level of standard deviation could be regarded as the base level of noise in the grid. 

8.3 EXAMINING OVERLAPS 

You can use the grid to compare the overlap between survey lines. Import an overlapping 
survey line into the grid, and use the Average, Standard Deviation, and Range views to inspect 
the overlapping area. You can use the Status button to check the numerical differences for 
selected bins in the overlap area. 

If you want to remove the effect of noise within individual survey lines, and concentrate on 
the differences between them, run a Smoothing filter, with the … only the same line setting 
selected. This has the effect of collapsing the standard deviations within individual bins to zero. 
Any standard deviations and ranges remaining are then due purely to the difference between 
lines. 
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Alternatively, you can measure the difference between survey lines by creating a difference 
grid. To do this, import one or more "base-level" lines into the grid. Then, set the Subtract 
Import From Existing setting in the Import Filter dialog in Tools. Import the data that you wish 
to subtract from the base level survey. This can be any data type: processed data file, ASCII 
xyz, or another grid. The final result is a grid containing the difference between the original 
grid and the data set that you imported after setting Subtract Import From Existing. You can 
view this in the normal way, except that, of course, all the values seen in the grid are 
differences, not depths. 

8.4 USING PROFILES 

To view a profile of depths in part of the grid, use Tools > Select Profile, or click on the Select 
Profile button. Use click-and-drag in the view area to select the track of the profile to be drawn. 
The profile will be shown in elevation view at the bottom of the grid view window. It is scaled 
to fit this window area, and the depth scale is shown at the side, with the length scale along 
the profile at the bottom. You can compare profiles from different lines by selecting Cross 
Section > Separate Lines in the view context menu.  

This method of comparing profiles is also a powerful calibration tool: see below. 

You can turn off the profile view by de-selecting Cross Section > Show Line in the view context 
menu. 

8.5 USING 3D VIEW 

In 3D view, depth errors can be seen very clearly as “spikes” in the surface. 
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9 CALIBRATION 

9.1 PATCH TEST CALIBRATION 

Grid Processor supports a process called “patch test calibration”. This allows errors in the 
parameters used in data processing (in Swath Processor) to be measured, by comparing 
overlapping data sets. If we can assume that the seabed has not changed between the survey 
runs, then any differences must come from errors in the offsets used in the data processing, 
so we can measure those errors. 

9.2 CALIBRATION METHODS 

Grid Processor provides two types of calibration process: “V-graph” and “fast”. The V-graph 
method is more accurate, but takes a lot more computer power, and so takes longer to 
complete.  

9.2.1 V-Graph Calibration 

In the V-graph methods, the data in the grid is shifted according to the type of calibration being 
done (for example, transducer elevation angle), and the average depth difference between 
overlapping areas of the grid is calculated. Then the data is shifted again by a different amount, 
a new depth difference is calculated, and so on for a range of shifts, plus and minus. The 
resulting differences are shown on a graph, which gives a “V” shape, with the best fit at the 
bottom of the V. 

 
Figure 1 Calibration V-graph 

The result is then refined, by choosing a narrower range of shifts around the best-fit shift, and 
with smaller steps in shift, until the required resolution is found. 

The V-graph method is accurate, because it finds the best fit for a wide area of the grid (not 
just a small selected sample). The displayed graph gives a good indication of the sensitivity and 
accuracy of the process: if the graph does not obviously have one good minimum, then the 
survey area and line pair area chosen will not give a good calibration result.  
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9.2.2 Fast Methods 

The V-graph process is slow, as it repeatedly re-processes large areas of the grid. Therefore, 
“fast” methods are offered, which compare data extracted from sub-sets in the grid. For 
example, the roll-fast method extracts profiles from the grid from two overlapping survey lines 
and measures the angle between them. The result approximates to the roll offset between the 
lines, but is not the same as directly shifting transducer elevation angles.  

9.3 USING V-GRAPH CALIBRATION METHODS 

The method is the same for each of the V-graph tools: 

◼ Create a grid, in Detailed mode, using survey lines appropriate to the calibration 
process 

◼ If necessary, remove any significant depth “spikes” using Tools > Filters > De-spike. 
Use the 3D view mode to check for spikes. 

◼ Use Tools > Calibration to open the Calibration dialog 
◼ Select the Calibration Mode to use with the survey lines (e.g. Transducer elevation V) 
◼ Select the overlapping survey lines needed for the calibration method 
◼ Select the part of the grid that is appropriate for the calibration. For example, for 

Transducer Elevation, choose an area that is fairly flat, and where the survey lines are 
straight and parallel.  

◼ You can use: 
▪ Whole grid (so no need to select an area) 
▪ Rectangle: click on the Rectangle button, and then click-and-drag over a 

part of the grid to define a north-up rectangle to calibrate over 
▪ Polygon: click on the Polygon button, and then click on the grid to start 

selecting a polygon for the calibration area. Continue to click to add 
vertices to the polygon, and double-click to finish: the polygon is 
completed by joining the last vertex point to the first.  

◼ In Transducer Elevation and Roll calibration methods, you can see the 
overlapping area shown on the grid, if you select Show Cal. Overlap Lines in the 
grid context menu (right-click on the grid). 

◼ Click Start Cal, and wait for the process to finish 
◼ Check that the V-graph shows a clear minimum. If the minimum is off to one side, 

change the search area in the Calibration Search Parameters part of the dialog. You 
can increase the range of search, or the starting point. For example, a start angle of 1° 
and a range of 4° searches from -3° to 5°.  

◼ If the V-graph has a good minimum, then you will be shown the minimum shift, and 
asked “Accept this value?”. At this point, you probably want to refine the value, so 
answer No.  

◼ Click the Refine Settings button: this sets the start angle to the minimum found in the 
last stage, and halves the angle range and angle interval.  

◼ Click Start Cal again to repeat the process, and continue with Refine Settings until the 
required resolution is achieved (see the Angle interval setting).  
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◼ The refine-and-repeat process can be automated using the Automate to option. This 
repeats the calibrate-refine-repeat process until either the Angle interval is lower than 
the setting next to Automate to, or the calibration process fails to find a good 
minimum point.  

9.4 TRANSDUCER ELEVATION ANGLE OR ROLL CALIBRATION 

You need a grid with at least three overlapping survey lines, with each line running in an 
opposite direction to its neighbour. You can check the line direction using the Show Survey 
Lines setting from the view context menu (right-click in the view area). The survey line tracks 
are shown as lines overlaid on the grid, with the line number in a circle at the start of the line, 
and a cross at the end. 

These survey lines should have been specially run over an area of flat seabed: see the 
Calibration section of the Bathyswath online help manual. 

From Tools, bring up the Calibration dialog.  In Calibration Method, select Transducer 
Elevation V or Roll Fast (see above for the difference between the two methods). Click on Line 
A: Next Selected, and then click on a survey line in the grid view. Then, repeat with Line B, 
Next Selected, this time selecting the survey line adjacent to the one that you selected for line 
A. If you have difficulty seeing which line is which, select Line from View Type in the view 
context menu.  
The transducer elevation angle and roll calibration processes provide a Cal separately option, 
which is enabled by default. This ensures that, for a port-to-port calibration, only the port 
transducer data is used (and similarly for starboard). If you are processing MBES data, or have 
other reasons to compare data on the “wrong side”, then you can disable this setting.  
Click on the Start Cal button. The calibration process will run, and an average roll angle offset 
will be shown in a dialog box. If you think that this value looks reasonable (and you have no 
reason not to, yet), click on Accept Value. This value is then put towards the average 
calibration setting for that side (port or starboard). 

Repeat this process for all the survey lines in the calibration area. Check the results that you 
get for self-consistency. If you get some roll calibration values that seem to differ strongly from 
the others for the same side, then you can exclude them from the average by selecting Accept 
this value: No from the Calibration Report dialog. The calibration report dialog gives statistical 
information about the number of grid bins used to calculate the roll offset, the standard 
deviation of offsets measured, and so on. This information can help you to decide which 
measurements are likely to be reliable, and which are not. 

All the calibration results are stored in the Process Log: view this from the Tools menu. So, 
even if you feel that you have accepted the wrong calibration results, you can make your own 
average using the Process Log and the Windows calculator. 

When you have an offset that seems consistent, use the Shift Data function to apply the port 
and starboard roll offsets to the grid. Use the views to check that the overlap between the 
survey lines has improved. (See "Quality Control" above). Then, re-run the calibration process 
to make sure that the roll offset has reduced to an acceptable level. You can repeat this 
calibrate-shift process repeatedly to "home in" on an answer. However, as a final step, start 
again from an unshifted grid with the final roll calibration figures that you produce. This is 
because the quantisation of the data in the bin due to a finite bin size can cause small errors 
to build up on multiple shifts. 
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You can examine the area of overlap that was used for the roll calibration process, by selecting 
Show Cal. Overlap Lines in the view context menu. When the roll calibrator runs, it draws a 
line from each ping in Line A to the nearest ping in Line B. The data attached to these pings is 
then used as a centre for rotating the depths around in order to obtain a good fit of roll offset. 
This is fine if the survey lines are straight and parallel. However, if the survey lines have 
significant deviations from being parallel, then this process of profile line selection can give 
profile lines that are a long way from being at right-angles to the survey line. To minimise the 
problems that this may cause, you can use the Line Acceptance criteria in the Calibration Line 
Selection dialog. On the other hand, if the line selection process is causing the number of 
profile lines to be too small to make a good roll calibration, you can turn off the line selection 
criteria by selecting the Ignore Checks box. 

Alternatively, if the survey lines are acceptably straight and parallel for part of the survey only, 
you can select this area by de-selecting the Whole Grid tick box, clicking on the nearby Set 
button, and using click-and-drag in the grid view area to select the area that is to be used for 
calibration. 

9.5 POSITION-TIME OFFSET CALIBRATION  

Delays in the validity of position data used to be a major problem in surveying. However, it is 
becoming less so with the advent of faster, more intelligent positioning systems. Refer to your 
navigator or position system manual if you are unsure whether there is likely to be such a time 
offset. Also, refer to the Calibration section of the Swath Processor online help manual for 
further information. 

You need two survey lines that have been run at different speeds in the same direction over 
the same ground. The seabed needs at least one identifiable feature. 

Before you start, you should clean the data. Especially along-track, data can be noisy as 
unfiltered noise from the ship can affect results. Firstly, it is a good idea to use the point 
deletion in 3D to eliminate noise in the water-column. See “Selection” in “Viewing and 
Manipulating Data in 3D” (section 14) for information. 

Once this is done, use the despike filter. 

From Tools, bring up the Calibration dialog. You can use Position-Time V or Position-Time 
Fast.  

Click on Line A: Next Selected and then click on a survey line in the grid view. Then, repeat 
with Line B: Next Selected, this time selecting the survey line adjacent to the one that you 
selected for line A. If you have difficulty seeing which line is which, select Line from View Type 
in the view context menu. Alternatively, type the line numbers in directly. 

Now select a profile line, using Calibrate > Select Profile, Tools > Select Profile or the button 
on the toolbar. The program will advise you of an appropriate profile line to make. 

Select the width to calibrate across in Profile Line Parameters > Sample Width of Profile Line. 
This will provide a better average value for the offset, but using too large a width will cause 
other calibration errors to affect the result, such as heading. 

Click Start Cal. The calibration process should start.  
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For the Fast method, the ping is not used in this method; instead, the program will step across 
profile lines parallel to the one you selected across the width you selected. The calibration 
process will run, and an average offset will be shown in a dialog box. If you think that this value 
looks reasonable, click on Accept Value. This value is then put towards the average calibration 
setting). A standard error on the mean will also be given and recorded in the log with the mean. 
This gives an indication of the spread of results found by the process across the width selected. 
A large standard error does not necessarily mean poor quality results, though it may be a good 
idea to take more readings, as described below. Remember that it is important to check that 
results are roughly valid; if the result seems odd, check it against a result from another profile 
line. 

In order to gain more results to find an average value, different possibilities are available: 

◼ Use a different profile line along-track, to limit error caused by lines slightly off-
parallel to the track, and to gain an average of more than one result. Kinks in the 
track can be avoided by calibrating along two shorter profile lines either side of the 
kink consecutively. 

◼ Use different survey lines if available. 

Once you are satisfied with the result, follow the Shift Data procedure as mentioned in the Roll 
Calibration section above for the time offset. Despite the automation, user input is vital in 
producing good results. 

Note that position error not related to along-track error is not automated; this can be 
calibrated easily by measuring a suitable profile line using the Measure tool on the Depth 
Profile view. Make sure that 2 lines are selected in the Calibration Line Selection dialog and 
that the profile line is a straight line (not a curved or multiple-point line), otherwise the best 
fit displacement will not be shown. 

9.6 PITCH CALIBRATION 

Once you have calculated a position-time offset, and applied it to the processed data file, or 
directly to the grid, look at a pair of survey lines run in opposite directions.  

The method used is very similar to that used to calibrate for the time offset. The profile line 
should be placed along-track similarly, and multiple readings should be taken; user discretion 
should be applied in deciding the width of the line to be used; the default 10m is reasonable. 

Any residual error after position-time offset calibration is likely to be due to a pitch offset. 
Once again, you can confirm the pitch offset by applying the offset that you estimate using the 
pitch setting in the Shift Data function. 

9.6.1 Summary of Pitch and Position Offsets 

Pitch and position time offsets are the ones that tend to give most problems the first time that 
you do a post-processing calibration. If you are using good-quality position and attitude 
systems, then both of these offsets should be smaller than the calibration process can 
calculate. Beware of the following traps: 

◼ In shallow water (less than 20 metres) the effect of pitch offset is very small. So, if 
there is an uncorrected along-track position offset remaining from the position-time 
correction, this can be interpreted as a very large pitch error. Use your knowledge of 
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the transducer configuration on the vessel to consider whether pitch offsets in excess 
of 5 degrees are likely. 

◼ Some position systems have in-built predictor functions that completely remove the 
time offset. In this case, you should set the offset to zero and look for other causes of 
position error. 

◼ A very common cause of position offset is a wrongly applied position offset between 
the transducers and the positioning system. Again, some position systems allow this 
offset to be applied before the position is passed to the Bathyswath system. Check 
the settings of your position system. Alternatively, applying the transducer positions 
with the wrong sign causes the same sort of error. Refer to the Bathyswath online 
help of you are unsure. 

9.7 HEADING CALIBRATION 

Run two lines in opposite directions but parallel to each other at different distances. Use the 
method explained in the Position-Time Offset section, but run a profile line between the two 
lines. Alternatively, run a series of lines in the same direction, but at different distances from 
a recognisable target. Hence draw a profile line at a distance from both lines. In both cases, 
the profile should be taken parallel to both survey lines, across an identifiable feature or 
detailed seabed, and run parallel to both survey lines. 

As with position-time offsets and pitch, run multiple profiles to gain a better average result, 
and use results from more than one pair of lines if possible. See the Bathyswath Online User 
Guide for further details on this method. 

There may be a slight difference in heading error from port and starboard transducers, but this 
is usually very minimal and should only be calibrated for once all other errors are taken into 
account if a difference is suspected. Normally, an apparent difference will be due to another 
error, such as roll, instead. In the case that there is a subtle difference in heading between port 
and starboard, users may run the heading calibration twice; once for port-side profile lines, 
and once for starboard-side profile lines (port and starboard may be determined from the 
direction of the survey lines, and profile lines placed on the correct side). 

9.8 DEPTH OFFSETS 

Vertical depth shifts will generally be systematic across the whole survey, and thus hard to 
measure by comparing lines. However, misapplication of tide corrections will cause time-
dependant depth errors. These can be estimated by running crosslines at right angles to the 
main survey lines. Depth differences between these lines and the main lines can be measured 
by comparing the depth differences on profile lines, viewing separate profile lines for each 
survey line (Cross Section, then Separate Lines in the right-click menu). 

9.9 FORWARD-LOOKING TRANSDUCER CALIBRATION 

A forward-look transducer needs two angular offsets to be corrected for: 

◼ Elevation angle (angle from the horizontal) 

◼ Skew (rotation around the transducer’s axis) 

These can be computed from any survey line that has side-looking and forward-looking data; 
there is no need to use separate overlapping lines. However, the line used should be straight 
and over a flat seabed. 
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First, run the roll patch test procedures for the side-look transducers. Then reprocess one 
survey line using the corrected roll offsets. 

Import the survey line into Grid Processor, using Detailed grid format. 

In the Calibration Line Selection: 

◼ Select Forward Txer Elev and Skew in Calibration Method, 

◼ Select the line number, 

◼ Un-select all the transducers except the forward-looking one (usually Transducer 3), 

◼ Apply, and Start Cal. 

The forward-looking transducer calibration process is running a nested process over two 
angular dimensions, so runs more slowly than the other processes. You may need to select a 
line that isn’t too long. 

As with the other calibration processes, check the offsets given by entering them into Swath, 
re-processing, and repeating the calibration. 

9.10 VS REFERENCE METHODS 

There are several calibration methods that calibrate against a reference. These are: 

◼ Roll vs Reference, 
◼ Pitch vs Reference, 
◼ Height vs Reference, 
◼ Position vs Reference, 
◼ Heading vs Reference. 

In these methods, one survey line is selected for calibration (as line A), and all the other survey 
lines are assumed to be correct. Only the selected line is shifted, and compared with the other 
lines using a V-graph method (see section 9.3 above). This method is used, for example, with 
Bathyswath-PSM systems, where the mounting angles of the fixed, scanning transducer can 
be calibrated by comparison with a boat survey that has been done in the lake over the area 
being scanned. 

9.11 COMPLETING CALIBRATION 

When you have all the calibration results that you need, apply them in the offsets of the Swath 
Processor program, and produce a new set of processed data files for the calibration lines. 
Then, re-run the calibration processes described above to ensure that the new offsets that you 
calculate are within the error budget that you can accept for the survey. 

 

When you are happy with the calibration results, you can save grid space in the grids by not 
storing all the survey line data. Do this by enabling the Normal setting in the Settings > Grid 
dialog. 
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10 DATA EXPORT 

10.1 ASCII XYZ OUTPUT 

To export data to other programs, use the Export function from File in the toolbar. This saves 
the data in the grid as an ASCII xyz file. This format is accepted by most geographic visualisation 
and charting tools that are available. Use the Import-Export Format dialog to adjust the 
parameters of this xyz file.  

10.1.1 Import-Export Format 

You can select the format of ASCII data both on import and export. 

Select File > Import-Export Format. 

You can change the order of easting and northing in Data Order. 

The separator used could be a space, a comma, a semi-colon, or another character or sequence 
of characters. Enter it in the Separator box.  

Many geographic visualisation tools, particularly those designed for land-survey use, expect 
depths to be shown as positive-up. You can apply this to the export file by enabling the Invert 
Sign of Value setting. 

By default, Grid processor uses positive for depth and negative for heights above datum. 

Amplitude can be from “processed” or “raw” values; you can select the one to use if both are 
in the file. 

Grid processor stores many data items in each grid bin as well as just the depth. By default, 
the depth value is exported, but you can choose to import another type, or several types on 
each line, using the Data Type drop-down list. For example, you can export both depth and 
amplitude for each bin.  

10.1.2 Locations and values 

The grid is constructed so that the lower-left corner in easting and northing is the centre of 
the lower-left bin.  

The export function outputs the E,N coordinates of the bin centre and the average value in the 
bin, so the value you see on the end of each text line should be correct for the easting and 
northing numbers shown. 

10.2 EXPORTING GEO-REFERENCED IMAGE FILES 

You can export data as geo-referenced image files, for use as overlays in GIS packages, etc. Use 
File > Export Geo, and select from GeoVRML, GeoJpeg, or Surfer Binary. Note that some 
formats create two files: an image and a geo-referencing file (e.g. *.jpg and *.jgw). If you need 
to copy or move the image, use both files. 

10.2.1 Importing GeoJpeg file to QGIS 

You can use a GeoJpeg file created in Grid Processor as a layer in QGIS, as follows. 

• Grid Processor 
o use File > Export GEO > GeoJpeg 
o Specify a file name and location 

• In QGIS 
o Create a project 
o Import a background; I used OSM standard (Open street map) 
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o Click on Data Source Manager: 

 
o Select the Raster tab 
o Choose File 
o Use the ellipsis (...) button to choose the .jpg file 

 
o The file appears in the Layers list 

 
o It probably won't appear on the background in the right place yet, as you have to tell 

it what projection was used: the .jgw file uses projection coordinates, not latitude-
longitude 

o Right-click on the new layer entry, and choose Set CRS > Set Layer CRS 
o Choose the coordinate reference system from the very long list provided. You might 

need to check the Transformations dialog in Swath Processor. I had used the default 
WGS84 / UTM zone 30N 

o The image should now appear in the right place, but with a white background 
o To set the background to transparent 

▪ Right-click on the image file layer again, and choose Properties 
▪ Choose the Transparency tab 
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▪ Click the Add values from display button: 

 
▪ Then click on the white background of the image that you want to be 

transparent 
▪ (you could also use the Add values manually button (the top one), and enter 

255, 255, 255, 100) 
▪ The image should now appear in the correct place in the QGIS display. 
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11 VIEWING SIDESCAN INFORMATION 

Sidescan, or amplitude, data is stored in the grid bins alongside the depth information. This 
represents the strength of the returned signal from the seabed, “normalised” to remove the 
effects of distance from the transducers, beam shape and so on. 

View the sidescan information by right-clicking on the display to show the context menu, then 
select View Type and then Amplitude.  Now, the grid view is shown as a greyscale map, with 
the shade of grey proportional to the intensity of the sidescan return. This is equivalent to the 
sidescan mosaic that some sidescan systems can produce. However, these sidescan results are 
exactly placed in position, as the depth information removes the watercolumn range exactly. 

You may find that, to get a good sidescan view, you need to reduce the grid bin size to less that 
you would use with depths only. Then, you can find that there are gaps between pings along-
track. Use the Interpolate filter to remove these gaps.  

 

You can also view sidescan information in 3D view. Select Amplitude as the view type as above, 
and then switch to 3D view. Depth information will be used to show the height of the surface, 
which will be coloured according to amplitude. 
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12 TEXT PLOTS 

So far, these tutorials have used the colour-map display. It is also possible to view the 
information in the grid as numbers. To do this, right-click in the display area to show the view 
context menu, and place the mouse pointer over Views. Select the Text option. The view is 
updated to show text information overlaid on the colour map. Turn off the colour map by 
clicking on the Colour Map selection in Views, to disable it. 

The options for text are selected from the Text Settings dialog. This is brought up from the 
Text Settings… option in the view context menu. 

Each number shown is selected from a square "window" of bins. This window is the area under 
the number itself. The centre of the window is the centre of the text. The number can be 
derived from the numbers in the window in several ways: 

◼ Average: this is the average of the numbers in the window, 

◼ Count: this is the total of the depth counts in the grid bins in the window, 

◼ Maximum: this is the greatest value in the window, i.e., the deepest, 

◼ Minimum: this is the smallest value in the window, i.e., the shallowest, 

◼ Range: this is the difference between maximum and minimum. 

 

Note that in all these cases, the text appears at the centre of the window, even if the value 
selected (maximum, minimum, etc.) lies elsewhere in the square. 

The Text Interval is the distance between numbers, measured in metres on the ground. 

The number of decimal places shown with each number is selected with Decimal Places. If 
Count is selected for the Show type, then no decimal places are shown. 

The size of text on the display and on the printed sheet is selected in Text Size. This is nominally 
the height of the text in "points". 

The most common problem with printing text is that the numbers lie on top of each other and 
form a jumbled mess. There are two ways to remove this problem: 

◼ Increase the Text Interval, or, 

◼ Reduce the Text Size. 

 

However, if you are preparing a print, then check how the text appears using the Print Preview 
function from the File menu option. The relative text size and spacings are often quite different 
to that on the screen, particularly when a large print size is selected. 
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13 PRINTING AND PLOTTING 

To produce effective prints, you need to perform the following steps: 

13.1 SETTING UP THE VIEW 

Use the options described above to display the information that you wish to show.  

◼ Use the pan and zoom functions to select the area of the grid that is of interest. 

◼ Use the Text and Title dialog, from Settings, to enter a suitable title and description. 
The description might include information such as the dates of processing and 
survey, and the scale to be used. You can enter several lines of description if you 
wish. The display resizes itself to fit.  

◼ Use Print Setup from File to select the printer or plotter to be used, and the paper 
size and so on. 

◼ Use the Print Scales dialog, from File, to select the print scale. If you are not 
bothered about a particular scale, but you wish to use the whole of the page selected 
in Print Setup, then enable the Fit to Paper selection. 

◼ Use Print Preview, from File, to see how the finished result will appear on paper. You 
can zoom in and out of this preview using the buttons provided. You may well find 
that the preview is not quite as you would like it. This may be because the scale is 
wrong, or perhaps the relationship between text size and text spacing causes the 
numbers to overlap each other. If so, leave the Print Preview using its Close button, 
and modify the settings. Then go back to Print Preview to check that the plot is 
correct. 

Finally, print the page, either using the Print button in Print Preview, or from the Print option 
in File. 
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14 VIEWING AND MANIPULATING DATA IN 3D 

This section runs through the viewing modes, options and properties that are available in the 
3D view. 

14.1 GETTING STARTED 

◼ Open a grid in 2D, or import some data. For some of this tutorial you will need a 
Detailed grid open. 

◼ Select a small portion of the grid for further analysis. 

◼ Right click on the grid window. Now, select 3D Options → Show 3D. Alternatively, 
click the 2D → 3D button on the toolbar. 

◼ To look around, hold the left mouse button down and drag it around to rotate it. 
Zoom in and out using the mouse wheel. This is the Mouse Look view, and is useful 
for viewing small portions of the data as a whole. 

◼ The view uses the centre of the selected area in the 2D view as its centre of rotation, 
so in order to centre on another part of the grid, you can return to the 2D view. 

◼ The scale box around the grid will display Northing, Easting and depth data at its 
edges. The depth data displays maximum and minimum depth values. A North arrow 
is also shown, as is the same colour legend as the 2D view. 

◼ The minimap in the top right corner displays your location and direction in the 3D 
view. The box is scaled to be square, so will not be scaled to the same sizes along x 
and y. 

14.2 FURTHER OPTIONS 

◼ Right click again on the window. This time, select 3D Options > 3D Properties. 
Alternatively, click the 3D Properties button on the toolbar, marked with ’3D’ and a 
ticked box. This will bring up a dialog box. Move it so that it leaves the view 
unobstructed. Each time you change an option, you can select Apply to view your 
changes whilst still in the dialog. 

◼ There are various properties that you can set on the 3D View. The first is Height 
Exaggeration. This sets the factor by which the height of each point is altered. Enter 5 
into the edit box and press Apply to see the difference. The range of the 
exaggeration factor is from 0.1 to 100. 

◼ View type is listed next. We’ll cover these later, since they require some explanation. 

◼ Next is the View Mode. There are essentially two view modes in 3D, with the option 
to view both. Grid displays the grid as a coloured heightmap; Point Cloud displays 
each data sample as a dot in space. You cannot view point cloud information in a 
‘normal’ grid or after smoothing data using the ‘smooth’ filter. 

◼ The Control Mode specifies which control mode you wish to use for the 3D view; the 
default mouse/keyboard mode, or the Directed Speed keyboard-only mode. The 
keyboard/mouse controls use the mouse to rotate and move up/down or zoom and 
the keyboard to move around in free flight. The DS keyboard mode allows the user to 
direct the speed at which they are travelling by pressing the up/down arrows to 
move faster or, 
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◼ slower in Free Flight or Height Locked views, plus a variety of alternative controls to 
the mouse, as listed in the control summary below. 

◼ The ‘Advanced Options’ set graphical detail levels and view.  

◼ Loop Fly Through loops the flythrough until the user escapes it. 

◼ Show Hidden Points displays points that the user has selected to be hidden in 
the Point Cloud 

◼ Show Only Interesting Points shows only the data marked as Interesting in the 
Point Cloud. 

◼ Set Fixed Flythrough Depth sets the Flythrough and height-locked modes to 
stay fixed to a specified height relative to sea level. Disabling the option (as is 
the default setting) will allow the camera to follow the altitude of the 
bathymetry below. 

◼ ‘Graphical Effects Options’ deal with options that affect the 3D graphics 

▪ Sea Surface allows you to turn on or off a plane above the data that is 
displayed at zero depth (i.e. at sea level or from the base plane set when 
gathering the data). Bear in mind that this may not work well if using 
data which is above sea level (e.g. a river) and which has altitude data in 
it. 

▪ Lighting turns on the sun illumination. This slows the drawing down but 
can be very useful for bringing to light different attributes of the seabed 
and objects that might otherwise not be highlighted by the colouring. 

▪ Detail Reduction on Movement reduces the amount of points drawn 
when viewed from a distance in the Mouse Look view or when moving 
the view to reduce draw. This is useful when viewing a lot of data at 
once or when using the grid program on a slower machine. 

▪ Positional Lighting is a mode of lighting that turns the light source into a 
locally positioned light bulb as opposed to sun illumination. 

▪ Show Light Position displays in the 3D view a small light bulb 
representing the position or vector from the centre of the light. It can be 
rotated by holding down ‘l’ using the arrow keys. The light is locked to a 
sphere around the centre of the grid, so at the apex and bottom of the 
sphere the left and right rotation will have negligible effect on the 
position. This option can be very useful for showing up sand waves on 
the seabed or other objects by lighting from one side. Changing the light 
position does not require this option to be checked. 

◼ Grid Draw Properties has 2 modes: Wireframe and Shaded Heightmap. 
Shaded heightmap is the default, showing the grid as a flat surface of filled 
polygons. The wireframe mode draws a wire grid between the points. 

◼ Ambient and Diffuse light are two different ways of casting light onto a 
surface. 
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▪ Ambient light is the background light level in a volume, not based on 
direction or proximity to a light source. All surfaces are lit the same 
amount. This value is set between 0 and 1. 

▪ Diffuse light is the light that is shone directly onto a surface. It is 
dependent on angle to the light source, so surfaces facing away from it 
will appear darker, even close to black if the ambient light is set to 0. 
Again, the value is set between 0 and 1. 

▪ Setting Ambient to 1 and Diffuse to 0 is roughly equivalent to turning off 
lighting entirely. However, it is slower than simply turning off lighting, so 
it is probably better to either use some diffuse lighting or turn off 
lighting altogether. Also, it is generally a good idea to make the ambient 
and diffuse values add up to 1, as beyond this the colour of brighter 
surfaces begins to become white. 

◼ View Distance specifies the distance, in metres, that you can see. Increasing it 
will allow you to see further but will make drawing the scene slower. The 
default value is 2 km, but a good value for a flythrough across a large grid is 
500m. 

◼ Free Flight Speed sets the speed in m/s at which the Free Flight view moves 
when the Mouse Control is on. The default is 20 m/s. Sometimes, if drawing 
times are large, the actual speed is slightly less than this setting’s value. 

◼ Strip Edit Width specifies the width of the strip you select for editing in Point 
Cloud mode, and hence the distance the strip jumps when you cycle the strips. 
For more information on strip editing, see ‘Selection’. 

◼ Point Size sets the width of the points drawn on the screen in pixels. The 
default value is 2. 

◼ Strip Edit Direction sets the direction that the strip will be oriented. 
South/North will display a strip that cycles in the North/South direction; 
West/East will cycle the strips in the West/East direction. For more 
information on strip editing, see ‘Selection’. 

◼ Show Minimap turns the minimap on and off. 

◼ Show Scale Labels allows you to set if and when the northing, easting and 
depth labels on the scale box appear 

You may alter the colours as per the 2D view, using the Colours and View Type options in the 
right-click menu. Point cloud data only accepts average or amplitude colouring; any other 
values set will default to average. Setting the colour band inputs to 1 colour and 1 shade, or 
setting a colour range entirely excluding the data range will revert the point cloud to single 
colour. 

You can save images of the 3D view by using the Save Window option under File. This allows 
you to take screenshots of the 3D scenes and print them out. 

14.3 VIEW TYPES 

This section covers view types, i.e. the ways of moving through the 3D world. 
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◼ Select Mouse Look in Properties. Mouse look, as explained in Getting Started, centres 
the view on a point and allows the user to use the mouse to rotate around it. It is 
controlled by holding down the left mouse button and dragging left or right to rotate 
left or right, and up or down by rotating up or down. Zooming is done using the mouse 
wheel. You may move the view centre using the {, @, : and ~ keys with the same 
arrangement as the arrow keys. 

◼ Select Free Flight in Properties. Free Flight allows free movement and rotation around 
the view. It is controlled by the mouse and keyboard combined. The arrow keys control 
movement forwards and backwards, left and right, relative to the direction you are 
facing in. Rotation is controlled in the same way as the mouse look, but looks out from 
a view position rather than down into one. Using the mouse wheel alters depth.  

◼ Select Height Locked in Properties. This view is identical to the Free Flight view except 
it is locked to a given plane to enable panning across the view without moving up or 
down at the same time. Its position, excepting depth, is shared by Free Flight and the 
Fly-Through mode, explained later. 

◼ To select the Free Flight position, return to 2D. You will see a black triangle on the 
screen. Click on the button marked ‘3D’ with an eye and a cross, and click on the grid. 
The triangle will move here. Clicking and dragging will set the direction of the triangle 
along the path that you drag. Returning to Free Flight or Height Locked view in 3D will 
set the position and direction of the camera to the ones selected in 2D. 

◼ Alternative controls without mouse input can be found using the DS keyboard-only 
mode. 

14.4 SELECTION AND DELETING DATA 

This section covers selecting points of interest or for deletion as outliers in Point Cloud mode. 

◼ Switch to 3D Point Cloud mode, and select a colouring arrangement and view type 
that does not include white colouring. 

◼ Select how you want to mark the data points that you select: 

◼ Delete (colours data white and allows you to delete it) – ‘x’ key 
This is the default. 

◼ Normal/default (ordinary colouring) – ‘n’ key 
Use this to “un-mark” points in the area you select. 

◼ Interesting (yellow; can set to only show interesting) – ‘i’ key 

◼ Hide (makes data invisible but not deleted) – ‘h’ key 

◼ Suspect (colours data red) – ‘u’ key 

◼ Double click on the screen at the edge of the area you want to select. Now single 
click in a path across the data. This will draw a line across the screen where you have 
clicked. You are unable to rotate the view during this. Click again several times to 
define a polygon. Double click to end the polygon.  
For example, if there are some points that are obviously outliers, use this method to 
draw a polygon around them. 
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◼ This will select all the data within the area you have selected bounded by the lines 
drawn on the screen. The default selection is marking points for deletion. There are 
numerous other flags available to set data to. For example, to select data as 
interesting, press ‘i’ and then carry the same selection process as described above. 
This colours the data yellow, and allows you to use the ‘Show Only Interesting Data’ 
option in 3D Properties that hides all data except the data marked interesting and 
colours it normally. 

◼ To select all the data, hold down the control (ctrl) key whilst double-clicking (you do 
not need to draw an area to do this). 

◼ To unselect data (set to normal), you can: 

◼ Hold down the shift key when you are double-clicking to make the final point 
in the selection area.  

◼ Use the ‘n’ key before selecting an area that you want to return to normal 

◼ Ctrl-shift-double click, or the ESC key, unselects all the data. 

14.4.1 Strip Editing 

◼ To select an individual strip to edit, click the toolbar’s Strip Editing On/Off button 
(marked with the word ‘EDIT’ in red and with strips in the background. This will turn 
on the strip-editing mode. You can change the orientation of the strips you view by 
selecting the direction in the 3D Properties dialog under Strip Edit Direction. You can 
also specify manually a direction by selecting the button marked with a pencil to the 
right of the arrow buttons, which brings you into 2D. Here you can select a profile 
line similarly to the Profile tool in 2D. Once selected, the tool will bring you back into 
3D where you can see the strip you selected for editing and step through it using the 
arrow buttons on the toolbar. 
To move between strips, click the arrow buttons to the right of the ‘EDIT’ button, or 
use Ctrl+left-arrow and Ctrl+right-arrow. 

◼ This mode is useful for mainly two things: highlighting and deletion/manual filtering. 

◼ Selecting an interesting object may be done by resizing the view in the 2D window 
around the object, then rotating until the object only is along the direction you are 
viewing, then selecting it. Rotating around will then show these points in highlighted 
colouring as noted above and the others in colour, allowing you to see objects 
highlighted against the other data. 

14.4.2 Deleting and marking points 

◼ Pressing delete or Z will bring up a message box asking you if you wish to delete the 
selected points. Selecting ‘OK’ will remove all the points marked for deletion 
(coloured white) permanently from the grid. Certain filters such as interpolation will 
create areas in the grid that cannot be deleted via point cloud deletion. You can opt 
not to show this dialog again during the current session with this grid file. 

◼ Point clouds may be viewed in the following ways: by depth (same for average, minimum, maximum 
and mode), by amplitude or by line. Types such as data count and standard deviation only make 
sense on a bin-by-bin basis; there is no standard deviation on a single point!   
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14.4.3 Delete and Un-delete 

There is no “un-delete” option: once a point has been deleted, it is removed from the grid and 
cannot be recovered. Therefore, we suggest the following strategy for deleting points from the 
grid: 

◼ Save the grid before you start editing it, so that you can return to that state if you 
change your mind about deleting points 

◼ Use the “mark suspect” (s key) or “hide” (h key) to mark points that you want to 
remove from the grid, before selecting them. 

◼ If you make a mistake, and accidentally mark a point that should not be deleted, use 
the ‘n’ key and select the points again to return them to normal. 

◼ When you are satisfied that you have selected only the points that you want to delete, 
use the Delete Suspect Points (Ctrl-Alt-S) or Delete Hidden Points (Ctrl-Alt-H) to delete 
them. 

◼ Alternatively, if you only have a few points to remove, it is simpler just to use the ‘x’ 
key to mark points for deletion and use Delete Marked Points or the Del key to delete 
them, but remember that there is no un-delete in this case. 

14.5 FLY THROUGH MODE 

This section covers the automatic Fly Through option, useful for viewing a particular path in 
3D. 

◼ In 3D mode, click on the button marked ‘3D’ with the red arrow.  
◼ Go to the 2D view, then click on the grid. 
◼ A cross should appear. Selecting the button and clicking another time displays a line 

with the cross at the end. This is a navigation path, which you can fly along in 3D. You 
can also draw a curved line by holding down the mouse and dragging, letting go to end 
the line. These curved lines, since they are locked to individual grid bins, may appear 
jagged in the 3D flythrough. 

◼ To speed things up, try deselecting the Sea Surface and Lighting options in 3D 
Properties if neither is important, and turning on Detail Reduction with Distance. 
Whilst the 3D view has some inbuilt optimisation, displaying a large amount of data 
and/or using a slower machine to run it on may decrease the frame rate. 

◼ Once you are ready, right click on the window and select 3D Options > Start 3D 
Flythrough, or click on the 3D fly button. 

◼ The view will switch to 3D and begin flying through the grid. During the flight you may 
pause it using the ‘pause’ button and stop it at any time using the ‘escape’ button. You 
will not be able to switch back to 2D whilst the fly-through is running. When it comes 
to an end, it will return to height-locked view. 

◼ Viewing the point cloud information in this way is appreciably slower than the grid, 
since it displays a lot more data. It is advisable to either view the point cloud in this 
way with small areas of the grid if you wish to at all. 

◼ Pressing forwards will speed up the flythrough, and backwards will slow down or halt 
the flythrough. Using the mouse wheel in mouse control mode or Page Up/Down in 
keyboard-only mode will alter the depth of the flythrough. 

◼ The Loop Fly Through option loops the flythrough until the user escapes the loop by 
pressing ‘Escape’. This is useful for continual flythroughs in a single area.  
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14.6 RECORD VIDEO 

You can record the fly through moving image to a video file in .avi format. 

◼ Click on the AV button, and select a name and location for the video file 
◼ Set up a 3D fly through as described above and start it running 
◼ Click the AV button again to stop recording 

14.7 RESET 3D VIEW 

Sometimes you may get ‘lost’ in the grid and wish to reset where you are in the 3D world. To 
do this, click on the button marked ‘3D’ with a finger pressing a red button, or right click on 
the window and select 3D Options > Reset 3D View. 

14.8 STATUS IN 3D 

You can get statistics of the grid bins as you can in 2D using the Status tool in the toolbar, 
marked with a question mark. Select it, and then click on the grid. 

14.9 3D RECOMMENDATIONS AND OPTIMISATION TECHNIQUES 

Using computers without graphics cards or fast processors, or viewing large amounts of data 
may cause slowdowns as you view the 3D world. This section covers tips for speeding up the 
drawing. 

◼ Import at a larger bin size. The grid will improve its speed noticeably when doing this, 
at the cost of lighting quality and actual data count. Since bins are square, a reduction 
from 1m bins to 3m bins will produce a roughly ninefold improvement in speed, 
assuming drawing grid points is the most time-consuming operation in a draw. 

◼ Import a ‘normal’ detail level only. This will eliminate the point cloud data, but will take 
up less memory. Point cloud data is usually much denser than the ordinary grid point 
data, and can slow the viewing down if it is not essential to use it. 

◼ Change some of the advanced options. These include turning off lighting and sea 
surface, and turning on Detail Reduction on Movement. This reduces detail with 
distance in the Mouse Look mode, but will speed up viewing when moving on Free 
Flight and Height Locked views as well. Wireframe mode may also have some effect. 
Also, viewing both Point Cloud and Grid information may be slower than viewing one 
individually. 

◼ View a small amount of the grid by using the ‘Zoom Extents’ tool in 2D. This will also 
allow you to see the scale box around the view more effectively. This is a particularly 
useful technique for investigating individual objects or selecting small areas in the 
point cloud view as well. 

◼ Try not to open multiple 3D windows at the same time. The 3D view is quite memory-
intensive and as a result, combined with large grids in 2D may require a large amount 
of memory.  
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15 CONTROL SUMMARY 

This section lists keyboard and mouse controls used in Grid Processor. 

15.1 GENERAL COMMANDS 

15.1.1 Grid File Controls 

New Grid Ctrl + N 

Open Grid Ctrl + O 

Save Grid Ctrl + S 

Export Ctrl + E 

Import Ctrl + I 

15.1.2 Help 

Show the Key & Mouse dialog F1 key 

Show this manual Help > Show Manual, or use the button in the 
Key & Mouse dialog 

15.1.3 Display Mode 

Toggle between 2D and 3D views F3 key 

 

15.1.4 Processing 

Filter dialog Ctrl + F 

 

15.1.5 Calibration 

Calibration line selection Ctrl + shift + L 

Roll calibration settings Ctrl + shift + S 

Start calibration Ctrl + shift + C 

 

15.1.6 Information 

Process summary Ctrl + U 

Process log Ctrl + L 

Grid debug (show detailed and expandable 
information on the contents of the grid) 

Ctrl + shift + D 
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15.2 2D VIEW CONTROLS 

15.2.1 Zoom & Pan 

Rotate Hold down Left Mouse Button and drag 
up/down to rotate down/up and left/right to 
rotate left/right 

Zoom In Mouse Wheel Up (Away), PGUP key 

Zoom Out Mouse Wheel Down (Towards), PGDN key 

Pan left, right, up & down (relative to the 
orientation of the view, not the grid axes) 

Keyboard arrow keys 

 

15.3 3D VIEW CONTROLS 

15.3.1 Keyboard and Mouse Mode 

Mouse-Look 

Rotate Hold down Left Mouse Button and drag 
up/down to rotate down/up and left/right to 
rotate left/right 

Zoom In Mouse Wheel Up (Away), PGUP key 

Zoom Out Mouse Wheel Down (Towards), PGDN key 

Pan left, right, up & down (relative to the 
orientation of the view, not the grid axes) 

Keyboard arrow keys 

 

Free-Flight View & Height-Locked View 

Rotate Hold down Left Mouse Button and drag 
up/down to rotate down/up and left/right to 
rotate left/right 

Forwards Up Cursor Key 

Backwards Down Cursor Key 

Up Mouse Wheel Up 

Down Mouse Wheel Down 

Left Left Cursor Key 

Right Right Cursor Key 

 

15.3.2 Directed Speed Keyboard Only 

Mouse-Look 
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Rotate Cursor Keys 

Zoom In Page Up 

Zoom Out Page Down 

 

Free-Flight View & Height Locked View 

Rotate Left/Right Left/Right Arrow Keys 

Increase forwards velocity Up Cursor Key 

Decrease forwards velocity / reverse Down Cursor Key 

Up Page Up 

Down Page Down 

Pitch/Rotate Up Home Key 

Pitch/Rotate Down End Key 

Stop Moving Space 

15.3.3 Other Controls 

Fly Through 

Increase Velocity Up Cursor Key 

Decrease Velocity / Stop Down Cursor Key 

Increase Depth of Camera Page Down (Keyboard-only) 

Mouse Wheel down (Mouse control on) 

Decrease Depth of Camera Page Up (Keyboard-only) 

Mouse Wheel up (Mouse control on) 

Pause Flight Pause Key 

End Flight Escape 

 

Point Cloud Selection 

Start Point Cloud Selection Area Double Left Click 

Add Node to Point Cloud Selection Area Single Left Click 

End Point Cloud Selection Area Double Left Click 

Deselect Points in Area Shift + Double Left Click to end selection of 
area 

Select All Points Ctrl + Double Left Click 

Deselect All Points Ctrl + Shift + Double Left Click to end selection 
of area 
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Mark Points for Deletion X key 

Mark Points Interesting I key 

Mark Points Suspect U key 

Mark Points Hidden H key 

Mark Points in Normal mode N key 

Undo selection and return to normal ESC key 

Delete Points Marked for Deletion Delete or Z key 

Delete points marked Suspect Ctrl + Alt + S 

Delete points marked Hidden Ctrl + Alt + H 

 

Light Position Controls 

Light Rotate Vertically L + Up/Down Cursor Key 

Light Rotate Horizontally L + Left/Right Cursor Key 

 

3D-Related Controls in 2D View 

Delete Last Navigation Path Point Delete 

Delete All Navigation Path Points Ctrl + Delete 

  

Strip Edit 

Previous strip  Ctrl + left arrow 

Next strip  Ctrl + right arrow 

 

 

  



 

 

The information contained on this sheet is subject to restrictions listed on the cover page of the document 

Version 5.13 – 19/10/21 Page 55 ETD-2003 

Unclassified 

www.iter-systems.com  

support@iter-systems.com 

16 TECHNICAL INFORMATION 

16.1 THE GRID 

The grid parameters are: 

◼ Bin size: the grid is divided into regular squares, and the input data is placed into the 
appropriate bin. The bin size defines the length of the side of each square. The bin size 
cannot be changed once it has been defined. 

◼ Grid area: the north, south, east and west extents of the bin define the working area 
of the grid. Any input data that falls outside this area is ignored.  

16.2 GRID STORAGE 

The during operation, the entire grid is stored in the computer memory. The data can be 
written to or read from a file on disk, but processing only occurs in memory. This speeds up 
the processing enormously, but places a limit on the size of grid that can be processed. Things 
that can be done to allow large grids include: 

◼ Use Normal mode grids for final processing and display of the whole survey area, and 
use Detailed for smaller areas for calibration and inspection of small areas in 3D 

◼ Use a 64-bit computer, and install the 64-bit version of Bathyswath software 
◼ Install more computer memory 

16.3 NORMAL AND DETAILED GRIDS 

Grids can store data in two levels of detail: Normal and Detailed.  

In a Normal grid, each grid bin contains: 

◼ The average of the depths that have been stored in the bin, 
◼ The average of the amplitude measurements that have been stored in the bin, 
◼ A quality factor. 

This format is optimised for size and speed, and is adequate for most seabed charting tasks. 

In a Detailed grid, every data point that falls within a grid bin is stored separately, and includes 
the following information: 

◼ The average of the depths that have been stored in the bin, 
◼ The average of the amplitude measurements that have been stored in the bin, 
◼ An optional quality factor, 
◼ A reference to the survey line that the sample came from, 
◼ The number of the Ping that the sample came from, 
◼ Absolute position (stored as an offset from the bin position). 

Although a Detailed grid format takes more space than the Normal format, it permits the 
following functions. These functions are therefore not available when using a Normal grid. 

◼ Filtering on the basis of line and ping number, 
◼ Grid statistics (range, standard deviation, etc.), 
◼ Calibration by comparing data from overlapping survey lines, 
◼ Data shifting by roll, pitch, heading, along and across track, etc. 
◼ Viewing of individual data points. This is particularly effective in the 3D Point Cloud 

mode, which allows vertical surfaces, overhangs and mid-water targets to be 
visualised. 
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A Detailed grid may be converted to a Normal grid, but not the other way around. 

 

16.3.1 File Size and Memory Size 

Grids take similar space in memory and as files on disk. 

Normal grids:  

◼ Empty bins:  4 bytes, 
◼ Data bins:  26 bytes, 
◼ Plus a few more kbytes for headers, etc.  

E.g., a 5km x 5km grid, with 1m grid bins, and 50% filled, will use about [(5000 x 5000 x 26 /2) 
+ (5000 x 5000 x 4 /2) = ] 360 Mbytes 

 

Detailed grids: 

◼ Empty bins:  4 bytes, 
◼ Data bins:  26 bytes + 2 per line + 12 per data point, 
◼ Plus a few more kbytes for headers, etc.  

The number of data points will depend on the filter settings used in Swath Processor. For 
example, a survey set up to meet the needs of IHO S44 Special Order will aim for more than 9 
points per square metre. So, for the example above, 5km x 5km grid, with 1m grid bins, and 
50% filled, the grid will use over 1700 Mbytes. 

16.4 FILTERS  

There are two reasons why you might wish to filter the data in the grid: 

◼ to remove poor quality data from the grid, 
◼ to fill in gaps in the grid. 

16.4.1 Filter Area 

A filter area can be selected or read in from file, as a polygon. When each filter runs, each grid 
bin is inspected to see if it lies inside or outside the polygon. Filtering can be configured to 
either filter all bins inside the polygon or all bins outside the polygon. 

16.4.2 Despike Filter 

This filter is used to remove depth values that disagree with their immediate neighbours by 
more than a given amount. The name comes from the fact that such depth values appear as 
"spikes" standing up from the data surface when viewed in a 3D-visualisation tool. 

The filter runs in a "sliding window". This is a square of grid bins, centred on the grid bin 
currently being filtered. The size of this window is selected by the … "grid units square" text 
box. For example, if a size of 3 is chosen, then the sliding window consists of the current grid 
bin, and the eight bins immediately surrounding it. If the size is set to 5, then there are two 
layers of bins surrounding the centre bin; and so on. If you select an even-numbered window 
size, then the number is rounded up to the nearest odd number. 
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The despike filter calculates the median value of all the grid bins in the sliding window. It 
compares the value in the centre bin with this median. If it differs by more than the set amount 
("remove values deviating by more than…"), then the grid bin is emptied. Otherwise, it is left 
alone.  

If the grid bins are sparsely occupied, then the comparison is not meaningful. Therefore, you 
have the option to delete all bins where the square of bins in the moving window is filled by 
less than a given percentage ("but remove the value if the square is less than" … "% full"). 
Increasing this setting removes more of the data. If you set it to 100%, then all values are 
deleted. If you set it to 0%, then values that are on their own in the bin are not deleted, even 
though there is nothing to compare them with. 

The statistical information and survey line information of data points that survive the Despike 
Filter process are not affected. 

16.4.3 Smoothing Filter 

The effect of this filter is to smooth the surface of the grid, by averaging each grid bin with the 
contents of its neighbours. 

This filter also uses a sliding window: see the Despike Filter.  

The filter calculates a weighted mean of the values in the sliding window square. The centre 
bin gets the highest weight, and the outer layer of bins gets the lowest weight. The value of 
the centre bin is replaced with this weighted mean. 

When this filter is used before comparing survey lines in a calibration or quality control 
process, it is not a good idea to average together values between survey lines. Therefore, you 
have the option to use values only from the same survey line when the average is selected. 
This option works as follows. The centre bin is examined, and the value for each survey line is 
extracted. For each of these survey lines, a weighted mean of the values in the sliding window 
is calculated, in each case using only values that originated from the same survey line. This 
value is then used to replace the value in the centre bin that applies to that survey line, and 
the process is repeated for the other survey line values in the centre bin.  

A value is placed into the centre bin, even if it was originally empty. This filter is therefore a 
useful way to fill in small gaps in the grid. If you want to fill in gaps in this way, but not to 
smooth the existing data, select the "change" … "only empty bins" setting. 

This filter destroys statistical information (standard deviation, maximum and minimum), but 
retains the survey line structure. 

16.4.4 Remove Data 

This filter allows selected data to be removed from the grid. The options are: 

◼ Any data: this removes all data values. It is therefore only useful if used in conjunction 
with the "Filter Area" selections. 

◼ Value Less Than: removes values which are less than the value entered (i.e. shallower). 
◼ Value More Than: removes values which are more than the value entered (i.e. 

deeper). 
◼ Standard Deviation More Than: removes the value in the bin if the standard deviation 

value in the bin is greater than the value entered. 
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◼ Range Value More Than: removes the value in the bin if the difference between the 
maximum and minimum values stored in the grid is greater than the value entered. 

◼ Count Less Than: removed the value in the bin if the count of imported values in the 
bin is less than the value entered. 

◼ Line Number of: removes all values for the line number entered. 
◼ Max. Horiz. Range of: removes all values that are more than a given horizontal 

distance from their ping origin location. Values can be set for port and starboard 
ranges. 

The statistical information and survey line information of data points that survive the Remove 
Data process are not affected. 

16.4.5 Interpolate 

This filter fills in gaps between and around existing data. The range that is used for searching 
for existing data is set in the "… using a maximum range of" … "bin units" setting. 

The interpolated points have no statistical information or survey line information. 
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