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01: Reading raw data files
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START SWATH PROCESSOR &
OPEN THE SESSION FILE &
RAW DATA FILE



ﬂ OPEN THE SESSION FILE

ITER SYSTEMS

Double-click the Swath Processor icon.



OPEN THE SESSION FILE

Open a session (.sxs) file. You can use File, and Open from the menu bar ...



OPEN THE SESSION FILE
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... or use the Open button ...



OPEN THE SESSION FILE

... or choose an item from the Previous File list.



OPEN THE SESSION FILE

\

Name Date modified Type Size
coverage 27/06/2016 08:05 File folder
sonar 04/08/2016 15:47 File folder
H about.txt 4 Text Document 1KB
@ izagse Double-click an sxs file from Windows

Explorer

.. or you can start Swath Processor using a session file by double-clicking on
the file you want in Windows Explorer.
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SWATH PROCESSOR

. Status

[11:59:25, 14-10-2016 Defaulting to English language version
Error: 11:59:30. 14-10-2016 No hardware detected

Swath processor starts, with the view windows
that were saved in the session file.
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SWATH PROCESSOR CONTROLS

You control the program using: - The menu bar ...
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SWATH PROCESSOR CONTROLS
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You control the program using: - The tool bar ...



SWATH PROCESSOR CONTROLS

Not Saving Data

ot Soving Date

You control the program using: - The main dialog bar ...



SWATH PROCESSOR VIEWS

Mod Soving Dhodn

You can see information in: - The view windows ...



SWATH PROCESSOR STATUS

Hod Saving Dain

Mo Swing Dinin

You can see information in: - The status lights



Mot Saving Data

SWATH PROCESSOR STATUS BAR

You can see information in: - The status bar



Mot Saving Data

PROJECT STRUCTURE

Set up the project structure to easily find stored data:
Click Configuration, then Project Structure.



PROJECT STRUCTURE

Project Structure

oject structure

]

[ Use Project File Structure

Select Use Pr

IC:\Snnar Data\Bathyswath Data\Software %t Data\F

mrowse.. | Assxsfile |

Raw data

Directory I

File Name Prefix I

[~ Break Up Files by Time |—60_ minutes
‘ Processed data sonar\proc

Settings logs ‘F

Settings files W

Main fifter sattings [main fier

Main filter change [Fln_fﬂ!er—

Parsed filter settings 1 W

Parsed filter 1 change
Parsed filter settings 2
Parsed filter 2 change
Actions log

Target log

Attitude files

Position

Coverage files

Track plan

Coverage vector files

Tide data files

Speed of sound data

S
E—

<root>\sonar\proc
<root>\logs
<root>\logs\settings
<root>\logs\main_filter
<root>\logs\main_filter
<root>\logs\parsed_filter_1
<root>\logs\parsed_filter_1
<root>\logs\parsed_filter_2
<root>\logs\parsed_filter_2
<root>\logs\actions
<root>\logs\targets
<root>\auxiliary\attitude
<root>\auxiliary\position
<root>\coverage
<root>\coverage

<root>\coverage

[

<root

e

<root.

Help

To make it easier to find the data files, select Use Project Structure, and
then use As SXS File, or Browse to find the location of the sxs file.




Hat Soving Dinin

OPEN A RAW DATA FILE

To open a raw data file, click Input File.



OPEN A RAW DATA FILE

nput File

Open . | Find the data files
No file open at preseht

Fead Rewnd

[v Loop data

Slow _} Fast

[ Save Coverage Data

[ Don'tupdate views, for speed

0% offile 0 outof 0

[
Help | Applyl OK |

Use the Open button...



OPEN A RAW DATA FILE

’\ Oner
™ « Bathyswath Data > Demo Data > large > 2015_BSW2_Vizag_India > sonar > raw v O  Searchraw P
Organise ¥ New folder = ™M @
A Name \ Date modified Type Size
# Qui »
& D [] fh 260 ed.sxr 04/01/2016 0959  SX
- e 180 e 04/01/2016 0953 8 Se|ect one or more f||es
[ ] sunken jetty.sxr 04/01/2016 09:55  SX
{# D
& Pi
Sc
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E
File name: Select Other file types T‘ Raw Sonar Data (*.sxr) v
Open |v Cancel

You can double-click one file, or click-and-drag over several files
Defaults to .SXR (raw) files, but can also read .SXI (parsed) and .SXP
(processed), using the dropdown list at the bottom-right.



OPEN A RAW DATA FILE

nput File

Open ... Close File [

...._Vizag_Indigisonar\rawifh 260 ed.sxr

Read | Start readi

[7 Loop data

Slow _} iR Control the reading speed

[ Sawve Coverage Data
Bl b L Can speed up by turning off views
0% offile 1 outof 3

Help | Applyl OK |

Click Read to start reading the file.
Slow down the read speed to inspect data.
Or can process at maximum speed by disabling views.



OPEN A RAW DATA FILE

Open ...

..._Vizag_India\sonar\rawifh 268

Read Rewind

[~ Loop data
Slow

[~ Save Coverage Data
[ Don'tupdate views, for speed

0% offile 1 outof 3
Help | Apply | oK I

Click Rewind to return to the beginning.
Use Loop data to start again from the end.
Use Go To to start from a given ping or time.
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GETTING HELP



ONLINE USER GUIDE

f" Bathyswath Swath Processor. © Bathyswath - temp.sxs
File Configuration View Tools Window Help

D|=(@ &2 w| 6|s| ™| @B &  Help Topics 210 olD 100
. Status About Swath Processor ... CB m
08:34:11, 08-11-2016 Defaulting to English lakguage version Show 1 : p%: quo'n,

Error: 08:46:09, 08-11-2016 No hardware detected

Welcome to the Bathyswath )
Online User Guide BATHYSWATH

The Bathyswath User Documentation covers all models in the series. It is divided into two parts:

W This Online User Guide - covering all aspects of using the Bathyswath products as a hydrographic surveying
tool. The information is provided in topics and you can find information via the Contents, Index or Full Text
Search. From any topic, you can follow the hyperlinks (shown in coloured text and underiined) to see additional
information on the same or related topics.

. » 100 W Getting Started - the pdf and paper part of the documentation introduces the Bathyswath and Its various
Coverage 100m grid models and includes a high level discussion of the operating principles. It also covers practical aspects of
10pR I 2400 N ALO0 N 2000 N software and hardware Installation and deployment.

Use Help > Help Topics to open the Online User Guide.



ONLINE USER GUIDE

% Bathyswath Online User Guide - [m} %

H o= & o

Hide Back Print  Optiog

Contents ||gdex | §ealch|

Welcome to the Bathyswa
Online User Guide

@ @ About Surveying

® @ About Calibration

= @ Data Recording

@ @ Quality Control

@ @ Aboutthe Real-ime Software
@ Whatthe User Has to Do

The Bathyswath User Documentation covers all models in the series. It is divided into two parts:
@ @ Starting swath and Session Fil ) This Online User Guide - covering all aspects of using the Bathyswath products as a hydrographic surveying

tool. The information is provided in topics and you can find information via the Contents, Index or Full Text
Search. From any topic, you can follow the hyperlinks (shown in coloured text and underlined) to see additional
information on the same or related topics.

= @ Aboutthe User Interface
& @ Howto Set Up Data Inputs
@ @ Setting up Data Outputs

@ @ Configuration Prior to Process W Getting Started - the pdf and paper part of the documentation introduces the Bathyswath and its various
@ @ Monitoring Real-ime Data models and includes a high level discussion of the operating principles. It also covers practical aspects of
2 b software and hardware installation and deployment.

& @ How to Filter Bathymetric Datz

@ Sidescan Processing In addition, there are:
@ @ Static Scanning Systems W Grid Processor manual — this provides instruction for using the Bathyswath Grid Processor program.
@ @ Replaying Data Files
@ @ FaultFinding ” i ctions — the software and other comp are supplied with specific installation
® @ Testing instructions
g : Z;‘s;-rp;zile:smg W Auxiliary eq h is usually supplied with auxiliary equipment, such as attitude

sensors, post(lonmg systems and compases. These will have been supplied with their own manuals and/or

@ Interferometry - Basic Principle online guides, and the operator should also read these before using the system.

@ Menu Commands

[f] Contact Bathyswath For New Users - If you take a quick look at the contents list in the left frame of this Help window you will see that
Y the guide has been structured to lead you through usigé a Bathyswath system.

The surveying topics cover planning, preparation ap idance on using Bathyswath for surveying. The survey itself
is run and all data is collected by the Bathyswa et
calibration methods and practical advice on cg . °
About the Real-Time Software (swath) is L k t th t
the user has to do links the software activitie! I n S O O e r S e C I O n S
verifiable raw and processed data files. Links tal¥
Inputs, outputs and configure swath to particular Siglly situations.
A summary of the menu commands in swath can be Wund in the Menu Commands Summary List.
How to Monitor Real-Time Data leads into details of the different real-time data views available and gives guidance
on using the views in conjunction with the bathymetric filters to improve data quality.
There are also topics on interferometry principles and fault finding.
Assumptions

< > v

The panel on the left has:
Contents: click on the symbol to expand sections.



ONLINE USER GUIDE

[ Bathyswath Online User Guide - m] %
& & o
| Hide E Print  Optiog
.
Contents ||ndex | Seavch| A
[} wWelcome vy
® @ About Surveying eicome to € ba yswa
® @ About Calibration Online User Guide BATHYSWATH
@ @ Data Recording
= @ Quality Control
a : c&‘;‘:;":&z‘:'::‘:;g’gn"’ The Bathyswath User Documentation covers all models in the series. It is divided into two parts:
x This Onfine User Guide - covering all aspects of using the Bathyswath products as a hydrographic surveyin
o : }S\:ngmsv:Jam alnduj:ssmn kY e tool. The Iinformation is pvovlded’:g topics and you can find information via the Contents, lnoc?cx or Full Text ¢
8 e LS 1) 1 Search. From any topic, you can follow the hyperiinks (shown in coloured text and underlined) to see additional
® @ Howto SetUp Data Inputs information on the same or related topics.
@ @ Setting up Data Outputs
@ @ Configuration Prior to Process W Getting Started - the pdf and paper part of the documentation introduces the Bathyswath and its various
B @ Monitoring Reak-time Data mt;;:ls and m;:ludcs a high lc"vol discussion lof the operating principles. It also covers practical aspects of
| |& @ Howto Filter Bathymetric Data software and hardware installation and deployment.
1| @ Sidescan Processing In addttion, there are:
@ @ Static Scanning Systems W Grid Processor manual — this provides Instruction for using the Bathyswath Grid Processor program.
® @ Replaying Data Files
W@ Fault Finding W Installation instructions — the software and other components are supplied with specific installation
® @ Testing Instructions
2] : Post-processing W Auxiliary i Bathyswath is usually supplied with auxiliary equipment, such as attitude
@ Other Tools sensors, positioning systems and compasses. These will have been supplied with their own manuals and/or
@ interferometry - Basic Principl¢ online guides, and the operator should also read these before using the system.
?] g::;g%";:;:::m For New Users - If you take a quick look at the contents list in the left frame of this Help window you will see that
the guide has been nruc!ured to lead you through using a Bathyswath system.
The surveying topics cover p and guid: on using y h for surveying. The survey itself
Is run and all data is oollected by lm Balhyslvam Real ume Software (swath). The surveying topics lead on to
calbration methods and practical advice on carrying out a calibration sequence.
About the Real-Time Software (swath) is a good starting point for finding out what the software does. Then What
the user has to do links the software activities to the necessary user actions required to acquire high quality,
verifiable raw and processed data files. Links take you from here to more detalled information on how to set-up
inputs, outputs and configure swath to particular survey situations.
A summary of the menu commands in swath can be found in the Menu Commands Summary List.
How to Monitor Real-Time Data leads into detalls of the different real-time data views available and gives guidance
on using the views in conjunction with the bathymetric filters to improve data quality.
There are also topics on interferometry principles and fault finding.
Assumptions
< > v
B P U O v O VS TSPy - e

The panel on the left has:
Index: shows a list of keywords in alphabetical order,
Search: find pages that refer to a keyword.



CONTEXT-SENSITIVE HELP

Using the Waterfall view

0 ChaNgd Quchly between SMwent Gata Types i the wew

se the Set Typloal bumons, These ket you set e duplay

? s datn selections for Bathymatry, Sidescan, sad Ping
SLALSDCS i e button- dics

To show information about a view or dialog:
Click on the view to highlight it Press the F1 key,
Help appears at the page for that view.



TOOL-TIPS

View Tools Window He

Hold the mouse pointer over a button for a few seconds,
and a short text description appears.



SHORTCUT KEYS

Ctrl + N Open new session file Ctrl + B Clear all buffers

Ctrl+ O Open session file Ctrl + W New data view (window)

Ctrl +S Save session file Ctrl + F Show Bathy filters dialog

Ctrl+P Print Ctrl +T Show Sidescan processing dialog
Ctrl + 7 Undo Page Up Zoom in

Ctrl + X Cut Page Down Zoom out

Ctrl + C Copy Left arrow Pan left

Ctrl +V Paste Right arrow Pan right

Ctrl + F6 Show next view Up arrow Pan up

Ctrl + Shift + L Log cursor position in Waterfall View = Down arrow Pan down

Use the computer keyboard for quick controls.
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USING THE VIEWS



NEW WINDOW

e Bathyswath Swath Processor. © Bathyswath - vizag.sxs

File Configuration View Tools Window Help

Input

Sonar
MBES

Use the New Window button or Window > New Window from the menu bar.



: New Window: Select View Type

— Bathymetry & sidescan
. Waterall
Cross Profile (Bathy&SideScan)
Coverage Fing Stats
Enhanced Cross Profile
Side Scan Waterfall
Sensordata
Aftitude Compass
Text Sensor Graph
Test & diagnostics
Amplituce Angle & Phase
Status

NEW WINDOW

to select a Window

Click a button to select a window.



MOVING AND RESIZING WINDOWS

'\

DISIE] 81t] 8] ols | =] B ala]

Or
TCF/IP Socket 11O

Socket 1 - - -
Socket 2 | HE B

When a window opens, you can move it, resize it, minimise it to an icon in
the corner of the screen, make it fill the screen, or close it again.



TILE WINDOWS

L Bathyswath Swath Processor. © Bathyswath - temp.sxs

File Configuration View Tools Window Help

Olod 8¢ o o|eual & | |

o N el |
S . N =y
p— % Erfor: 13:55:48, 08-11-2016 No hardware detected
Error: 13:55:51, 08-11-2016 No hardware detected
L

Aualiary 3

Auxliary 4
Auxliary 5
Aualiary 6

Input File
1PPS
Ack |
Emor |

TCPAP Socket 110

You can tile the windows, so that they are rearranged to fill the space
available, using the Tile Windows button or Windows > Tile. Or, you can
make your own arrangement, which is saved in the session file.
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DEPTH & SIDESCAN VIEWS



CROSS-PROFILE VIEW

Can see depths, transducer, depth below transducers,
Right-click and select Properties to set up the view.



CROSS-PROFILE VIEW

AALAMI AP IIINE M F WRATWOMTLARAW S S AW S AW T WA

rofile View Properties

(" Parsed Channel 1 " S Horiz to 1 Depth A‘
(" Parsed Channel 2 " 10 Horiz to 1 Depth Help

. ~Transducers Displayed — (20 Horizto 1 Depth
Select [+ Transducer 1 —View Angle

[+ Transducer 2 [~ Fore-aft
transducers S

[~ Transducer 4 (MBES) = [ Join Points

Filtered & & Filtered ' Show Other ltems

- ~ Full [+ Madir Depths
unfiltered il vy S
[~ Display on White Background White or black

Select the items to see.



CROSS-PROFILE VIEW

Pan left-right, up-down using click & drag or keyboard arrow keys Zoom in &
out using mouse wheel or PGUP and PGDN keys.



WATERFALL VIEW

Shows new pings at the top of the screen, and moves the others down one step.
Pan left-right with keyboard arrow keys.
Can show:
Depths
Sidescan
Depth quality



WATERFALL VIEW

A Byt Poo-Statoud Taer 1, 2 25m 9ot Bandtin 1 00m Colours 6 Shadds=S Pouti~1

=

gg ursor position

&

Right-click to see the menu.
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Set up display
for each type

Transducers

Filtered or
Unfiltered data

WATERFALL VIEW PROPERTIES

E‘.d datﬂ

oces?

® Processed Datn
" Parsed Channal 1

A Datas
¢ Parsed Channcl 2 N9 ent out of Sockets

Range Correction
 MHone

Slant range
i® True Cormect

" Slant Correct p:TDCESSE'd
™ Shawe Fora-aR Orizont,| ra

@ 1 Poed . UH— Vie

2 Poosls
4 Pols

Select display properties.



Click the

Sidescan button

Use the Sidescan button to set up the waterfall view for sidescan.

_ S |
Transducers Displayed
[v Transducer 1
v Transducer 2
[~ Trensducer 3
[T Transducer 4 (MSES)
Show Data
@ Fitared
¢ Full
[ Unprocessed Sidescan
[T Rejected
[ interpolated

WATERFALL VIEW SIDESCAN

Ping Source

@ Processed Data L]
" Parsed Channel 1 L}
" Parsed Channel 2 weo |

Range Correction
" None

@ True Correct
(" Shet Corect
I~ Show Fore-Aft

Seroll

® 1 Posl
2 Puels
4 Puels

| Display on White Background
[~ P Colours

[~ Suppress Clear

[~ Show Position Ticks




J WATERFALL VIEW SIDESCAN

Waterfall view can show sidescan data as well as depths. Strong returns are shown
black, weak returns white.



WATERFALL VIEW CURSOR

Click on the screen to place a cursor (shown as a cross on the screen)
Position and depth is shown at the bottom of the view.



WATERFALL VIEW CURSOR LOG

Right-click on view and select Log Cursor Position (or Ctrl-Shift-L keys) Use Tools >
Target Log to see the log and save to a file.



COVERAGE VIEW

"
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Coverage view shows depth or sidescan data in a plan-view map.



COVERAGE VIEW MENU

Show the Settings

! dialog
Click on display to show Centre On CurrelRg==
Pick Point

position — Click-and-drag on
Click on display several i display to measure
times, then double-click Clear Data

Right-click to show the Coverage view menu.



COVERAGE VIEW SETTINGS

Coverage Settings

Rocerbe

[¢ Cama onVasaal Wien Ou ol View / What to do When the
[~ Cortre on Vessel Now -

€ S - boat leaves the view
[v Show soner dats Calours . CO'our Sca'e

Febosh every F'o pings

@ StowDept  Snwes |1 m

" ShowSideromn cdase (000 »
L)

Depth or

sidescan

[ Only updata whaos witng of readng Hes

EVPs -
[T ShowSVPs Colour HIGH BLLE

Choose Settings from the right-click menu

Data is stored in a grid in memory; when boat leaves the stored grid area,
a new one is made.



COVERAGE VIEW SETTINGS

o

Turn vessel and track Panlion ok =]

[ Shosswarasal poskion

on and off R e B I

Show data from other S | —

files on disk -
Create and show a ' ' -
track plan to follow Bwee g —
Show a base map o= |
Show DXF etc.

Vecole o e Losdetonguie 0%
Pokgyan Fibar Bo roary
[# Shss pakegon Colour [l4D_vELLDW -

EvPy

Location of SVP dips Fomsn  GlesfEEE =

Selected polygon shape

You can:
Create and show a line plan to follow for a survey
= Show a base map from Geotiff etc.
= Qverlay vectors (e.g. DXF)
= Show location of SVP dips
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CHECK SENSOR DATA



ATTITUDE VIEW

=

See the Attitude sensor data at a glance.




SENSOR GRAPH

Show a scrolling graph or roll, pitch, height and heading.
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TEST & DIAGNOSTICS



y TEST AND DIAGNOSTICS VIEWS

MNew Window: Select View Type x

t
t —Batymetry & sidescan Cancel
Cross Profile Beihy8SidaScan) Help |
Coverage Fing Stats
Enhancad Crass Prafil
Side Sc Watarall
Sensor data
Afitide Compass
Taxt Sensor Graph

a
Test & diagnostics
| Ampae prglo Phase | Test & Diagnostics views
Status

Test and diagnostics views are used to check that the sonar system is working well.




STATUS VIEW

. Status

=il

18:25:07, 18-10-2016 Defaulting to English language version
Error: 18:25:17, 18-10-2016 No hardware detected
Error: 18:25:19, 18-10-2016 No hardware detected
183157, 18-10-2016 Opening input file ChSonar Datall
Fing number: 6933: time: 04:03:35 16/1272015: Ping rejed
Ping number: 8934: time: 04:03:35 16/122015: Ping reje

Ping number: 8937: time: 04:03:35 16/122015: Pi
Ping number: 6938: time: 04:03:35 161272015 Pi

ath Data\Demo Datallargel2015_BSW2_V

Leave Status visible: it shows useful warnings and errors.



AMPLITUDE VIEW

B Amglitude 25m x 5000 grid
|

Shows the strength of return as a graph, against range
(distance from the transducers).



ANGLE AND PHASE VIEW

|

. B Angle and Phase —NRCIR X~

Shows the raw phase measurements from the sonar electronics,
and the angle from the transducer.
Used to check that the system is working correctly.
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MAIN DIALOG BAR



MAIN DIALOG BAR

Control system inputs

Status lights: green: OK; yellow: problem;
red: fault

Timing signal input
Output to other programs

Write raw data files

Write processed data files

Write position data files

The Main Dialog Bar on the left of the screen lets you control the system
and see its status.



MAIN DIALOG BAR

" Bathyswam Seath Frocessor. © Sathyswath - sempas

File Corfguation Vew Toos “ - -
e 3 Close the Main Dialog Bar
] o

OB34:11, 0B-11-2016 Detaultin £<

Error: 08:46:09, 06-11-2016 No
09:04:24, 08112016 Opening | ===
Py number: 58495 time: 050 ongan
'Ping number: 48496 time: 0% Poaxon
Piog number: SB497: time: 05

number: HE498 time: 05 =
09:368:29. 08-11-2006 End of iny  Aober

You can “undock” the Main Dialog Bar by clicking and dragging on its top border.
You can close it (to save window space), and you can open it again
from the View menu.



SAVING THE SESSION FILE



SAVING THE SESSION FILE

.- Bathyswath Swath Proceszor. © Bathyswath - temp.oe
File Configuration View Tools Window Help

D GRrw 6ls| = B

Inpua

= =) | IR
or: 13:55:48. 08-11-2016 Mo hardware detected
- 135551, 08-11-2016 No hardware detected

Sonar
WMBES |
Afiude .
Compass .
Fosition .
Aupiliary 1 .
Aupaliapy 2 .

Aupaliary 3

ALpaliary 4

Aipaliary 5

Aipaliary B

Input File

3

Ark [

e, HEN

TCOFAP Socket O

When you are happy with the way that the windows and other selections have been
set, use the Save button, File > Save, File > Save As, or Ctrl-S keys. The settings and
views will be restored when you next Open the file.
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